cancel
Showing results for 
Search instead for 
Did you mean: 

Defect with hardcoded date implementation

The recommended selection works correctly in both Report Editor and Power BI Desktop (and their reports):

TimoRiikonen_0-1623829416651.png

This shows date to all viewers according to their settings.

See more from my blog post on Microsoft site: https://community.powerbi.com/t5/Community-Blog-Staging-Private/Localization-in-Power-BI/ba-p/952439
But when you wish to hardcode it to regional settings, then Report Editor works correctly and Power BI Desktop works incorrectly:

TimoRiikonen_1-1623829591834.png

As you can see even the Desktop choice doesn't make any sense. 14.03.2001 is dd.mm.yyyy, not dd/mm/yyyy as it says in parenthesis.

Day / month order is changed correctly, but "/" character needs to be changed to "." as my regional settings say.

You can perhaps copy the implementation from Report Builder where this worked correctly the last time I used it (2020).

P.S. Suggestion: make the default date format as *d.m.yyyy instead of the long format it is now. For backward compatibility you would need to make this change as setting.

Status: New
Comments
TimoRiikonen
Helper III

Also it looks like you need to reboot Windows before you test this.

Here is image after I changed Regional format to en/US:

TimoRiikonen_0-1623836726055.pngTimoRiikonen_1-1623836755153.png

 

Here dates "31/03/2015" and "6/20/1995" had been both coded with setting dd/mm/yyyy (which should be dd.mm.yyyy).

And "31.3.2015" had been coded with setting *d.d.yyyy. I had restarted Chrome after changing Windows locate, but results are getting random still. I haven't tested after rebooting Windows, but I would expect that to fix the results for testing.

 

v-lili6-msft
Community Support

hi

1.JPG

 

after set region to Finnish, it doesn't appear your problem.

 

could share the full repeat steps?

 

Regards,

Lin

 

 

TimoRiikonen
Helper III

I am not sure why you can't see the same. You could try these until you succeed

0) Change Windows region format to Finnish

1) Restart Desktop

2) Test again: select a date field

3) Reboot Windows

4) Test again

5) Download report from the bottom of this page https://community.powerbi.com/t5/Community-Blog/Top-N-with-Slicer-and-Steps/ba-p/952240

6) Open it and update it to latest version

7) Test again, this is how it works to me:

TimoRiikonen_0-1623919600632.png

 

v-lili6-msft
Community Support

hi

I have reported this issue internally, ICM:246273918

will update here once I get any information.

 

Regards,

Lin

v-lili6-msft
Community Support

hi

I get this from PG:

 
Please see the below comments for the suggested work around.
 

The bahaviour is by design.

Provided doc links and workaround to get the formatting required by CX

 

This is by design... The "/" symbol in formats is called a "Date separator" symbol and it's replaced with the current culture's date separation symbol when data is formatted...

The sample "14.03.2001" clearly states what is the expected results and it matches the formatting of data.  This also matches what you would get if you typed the dd/mm/yyyy custom format.

Here is more info re formatting strings: https://docs.microsoft.com/en-us/dax/format-function-dax

Workaround: You can escape the date separator symbols: Type "dd\/mm\/yyyy" custom DAX format expression in the Format box.

 

 

 

Regards,

Lin

TimoRiikonen
Helper III

Hello,

I understand that the menu looks as it does.

But this defect is that the date separator doesn't change according to locale to reports.


In Germany and Finland, the end result of "d/m/yyyy" should be "25.6.2020", but now it is "25/6/2020"!

So the date order is read from the correct place, but the delimiter setting is read from somewhere else and from wrong place.