cancel
Showing results for 
Search instead for 
Did you mean: 

Dataset refresh on existing in service does not work after converting Live connection to local model

Hi,

i have a report using Live connection to Azure Analysis Services. I wanted to enhance the report using What-if-parameter so i converted the model to a local model and added the what-if parameter. Everything works fine in the desktop but when i publish to the service i am not able to see the changes. The dataset does not seem to be updated, even if i unpublish the report and republish it again.

 

If i copy the report and publish a new one with new name so the dataset is created from scratch it works fine in the service. Can you give advice on how to be able to get the changes on existing report in effect?

 

Best regards

Jarle Jacobsen

Status: New
Comments
v-yingjl
Community Support

Hi @jarjac ,

Try to remove the data source in the gateway and re-configure for it to check when changing the initial report connection mode and re-publishing to Power BI Service.

 

Best Regards,
Community Support Team _ Yingjie Li

jarjac
Frequent Visitor

Hi @v-yingjl 

thanks for replying.

my datasources are Azure Analysis Services + What-if-parameter in Power BI. No gateway is used.

best regards

Jarle

 

jarjac
Frequent Visitor

Message when publishing from desktop

Refresh error.JPG

 

It is not possible to refresh data dataset in the service either.

v-yingjl
Community Support

Hi @jarjac ,

Based on the error message, you can try some workarounds mentioned in this simliar thread:

publishing is complete, however we couldn't refresh your dataset 

 

Best Regards,
Community Support Team _ Yingjie Li