cancel
Showing results for 
Search instead for 
Did you mean: 

Datamart broken after transforming data

My datamart is broken after doing some simple transforming of data... changing some colum types and filtering. It refuses to open and I cannot do anything anymore. Please fix this otherwise I lose a day of work...
 
Unable to open the datamart because it is not connected to its dataset. Wait a few seconds, and then try again.

Something went wrong

A bad request was encountered. Please try again. If the issue continues, please contact support.

Please try again later or contact support. If you contact support, please provide these details.
  • Activity IDd9833c7e-6b7c-4425-857f-2bf270a0d58a
  • Request ID13e0ee62-c771-d154-cc97-d2e563b5c836
  • Correlation ID07878d29-e4d5-1897-78e0-d71d25f1fa9f
  • TimeWed Jun 29 2022 16:20:29 GMT+0200 (Central European Summer Time)
  • Service version13.0.18489.36
  • Client version2206.2.11758-train
  • Cluster URIhttps://wabi-west-europe-d-primary-redirect.analysis.windows.net/
Status: Investigating

Thanks for the information, but still cannot reproduce it in my side when I tested again in a premium workspace with a SQL data source to create a datamart.

 

Suggest that you can consider create a support ticket under the end of this page for further fast help due to the security limiation of the community if this issue is urgent for you.

vyingjl_0-1656900264238.png

 

Best Regards,
Community Support Team _ Yingjie Li

 

 

 

Comments
v-yingjl
Community Support
Status changed to: Investigating

Could not reproduce it in my side as far as my test, when I created a datamart and did some tranformation for the data source to save it, it can be reopened to edit again.

 

Which data source you have used in the datamart? Did this issue happen in all PPU/Premium workspaces in Power BI Service? You can try to create a new datamart with the same data source in different workspaces to check, if it still has the same issue, you can consider sharing more details about your data source.

 

Best Regards,
Community Support Team _ Yingjie Li

FishSpecialish
Regular Visitor

Hi Yingjie,

 

Thank for the reply. Overnight the situation still seems unchanged. I used as a datasource a single SQL server with various tables, in which I had laid relationships. The relationships was not the issue, it were about 15 relations put together and worked. Later I added an Excel via Sharepoint, no issue there neither.

 

The Datamart however failed when doing what I believe just a simple transformation of one table. What I did there was filtering rows with a text based filter in one colum, so I could convert the datatype of the value column to decimal. I did error out there, as I was unaware those text based rows were written in the value column in the first place so I had to retry filtering and converting to decimal a few times. When I succeeded however, I first got an error which unfortunally I did not save... and did not remember. After that I exited the transformation window, got taken back to the main page of PowerBI, and was presented with a broken Datamart ever since.

 

The workspace I used is a premium workspace. Unfortunally the datamart with all its relationships do take time and it was the "correct" workspace where it needs to be. Otherwise I am working in workspaces for customer reports. I cant really just go around, making datamarts in those workspaces and spend alot of time getting it to work, build a report and then have it potentially crash again.

 

Is there nothing which can be done to restore / revive the Datamart I already made? It surely isnt right that it breaks down right that with no way to recover it.

FishSpecialish
Regular Visitor

I just remade the datamart, in the same (premium) workspace. I did the same transformations again, this time I did so correctly myself so I had it right on the first try. The Datamart continues to function as expected.

 

Thus I believe, that something bad and unrecoverable happens, if there are mistakes in the transformations, and you have to redo it a few times. That was atleast what happenend, with the breaking datamart of yesterday. That datamart is now not far off from 24 hours later, still unresponsive and giving the same error message.

FishSpecialish
Regular Visitor

@v-yingjl I now have a second broken Datamarket. I have once again lost all my work. This time I got the error preceeding it. This time, I also havent made a mistake in the query. It was a conditional column.

 

FishSpecialish_0-1656595446919.png

Before that, after saving my transform, I had a " Error 500 lock timed out", which allowed me to go back to editing. Retrying again gives me that message.

 

This datamarket today is now in the same state: "

Unable to open the datamart because it is not connected to its dataset. Wait a few seconds, and then try again."
 
Trying to restart it, gives the following:
 

We couldn't retry your suspended datamart

Fail to resume the suspended datamart
Please try again later or contact support. If you contact support, please provide these details.
  • Activity ID702777d1-1bd4-4385-ba80-e340e44a87ff
  • Request ID1ddc4729-643d-29f4-3fa4-792ef74a3854
  • Correlation IDa59c4a6e-2a89-c6d2-bd55-cc9b651af628
  • Status code400
  • TimeThu Jun 30 2022 17:57:37 GMT+0200 (Central European Summer Time)
  • Service version13.0.18489.36
  • Client version2206.2.11758-train
  • Cluster URIhttps://wabi-west-europe-d-primary-redirect.analysis.windows.net/
 
v-yingjl
Community Support
Status changed to: Investigating

Thanks for the information, but still cannot reproduce it in my side when I tested again in a premium workspace with a SQL data source to create a datamart.

 

Suggest that you can consider create a support ticket under the end of this page for further fast help due to the security limiation of the community if this issue is urgent for you.

vyingjl_0-1656900264238.png

 

Best Regards,
Community Support Team _ Yingjie Li