cancel
Showing results for 
Search instead for 
Did you mean: 

Dataflows with Excels are failing with "The field 'Hidden' of the record wasn't found"

Hi All,

 

Since today's morning my dataflows are failing with below error message and my source are excel files.

 

Expression.Error: The field 'Hidden' of the record wasn't found.

Details
Size = 20335449
Content Type = application/vnd.openxmlformats-officedocument.spreadsheetml.sheet
Kind = Excel File
Status: New
Comments
azemmama
New Member

I've been having the same problem since this morning.

miloslav_majek
Regular Visitor

Same issue here

sharpy86
Regular Visitor

Myself aswell, for a couple of days now. All of my dataflow refreshes are failing.

v-qiuyu-msft
Community Support

Hi all,

 

Did the issue happen when you refreshed the dataflow? Did the dataflow require any gateway? 

Please check if you encounter the issue listed here

 

q3.PNG

 

Best Regards,
Qiuyun Yu

 

 

miloslav_majek
Regular Visitor

No need for gateway -> the csv files are located on Sharepoint.

ncbshiva
Advocate V

Gateway is not required as we are refreshing the excel files stored in the SharePoint.

Not sure if any metadata has been changed in the SharePoint.

Anonymous
Not applicable

We are having same issue. 

 

 

Yesterday evening all was working but this morning none of dataflows are loading data and they get stuck on the step mentioned.

 

Error> The field 'Attributes' of the record wasn't found.

miloslav_majek
Regular Visitor

It seems that something changed on the Sharepoint side and it is no longer passing on the Hidden variable in the files attributes. Here is a workaround that worked for us assuming there are no hidden files in the filter/folder:

Leave out this line in the main query (obviously you have to also update the reference in the next step): 

 #"Filtered hidden files" = Table.SelectRows(Uroven2, each [Attributes][Hidden] <> true)
 
And also same logic has to be used (leave out the hidden files filter) in the Sample File helper query.
Anonymous
Not applicable

Hi again,

 

We followed the advice given by Miloslav and it worked. It was about to remove the  #"Filtered hidden files" step and that's it.

Don't understand why and what happened, but it works!


Thanks!

sharpy86
Regular Visitor

Brilliant, this worked for me! Removed the #"Filtered hidden files" line entirely, and updated the reference on the row below. 

 

Now the queries are refreshing.

 

Thank you Miloslav!