Showing results for 
Search instead for 
Did you mean: 

Dataflows fail to refresh - "pending validation" prevents to save dataflows

Power BI Dataflows have been systematically failing in the last 24 hours "because there was a problem with one or more entities, or because dataflow capabilities were unavailable". No matter if the dataflow queries our on-premises server or or a simple Excel file on SharePoint, it just fails. They have been running for a few months with no problem, beside isolated and temporary failures to refresh.

It seems that all dataflows are “pending validation”. When I open an entity and attempt to save it, it can’t save the entity/dataflow after the validation step fails. Herebelow is the error message that does not tell me much about the issue.

We have got a few organisational reports connected to these dataflows and users need daily refreshes. What can I do about it?


Activity ID: 95c94573-6caf-4ca8-852e-912384d12652

Request ID: 4bb0a5ae-8bb6-743c-de1d-96bba591a9c1

Correlation ID: c3ea76e7-0627-ab78-5866-29ab707d7fa0

Status code: 500

Time: Thu Aug 26 2021 07:52:52 GMT+0200 (Central European Summer Time)

Service version: 13.0.16650.58

Client version: 2108.3.07325-train

Cluster URI:


Status: New
Regular Visitor

@sfbind2, the error I had was similar Error: AzureBlobs failed to get the response: 'Unable to connect to the remote server'. 


I upgraded my workspace to Premium and that error went away and can refresh again. The dataflows are however still "Pending Validation"... I can edit and save them as well.

Regular Visitor

Has anyone had any updates on this? Our dataflows are constantly 'pending validation' and as of a couple of days ago a schema changes has caused multiple dataflows to start failing, I cant save (validation never completes) and I keep getting prompted for strange connection/credential requests randomly/inconsistently.


Any help at all would be much appreciated


All our workspaces have been premium and modern/upgraded for months.

Frequent Visitor

Same here - suubscribing to this thread in hope of a solution.

Frequent Visitor

@Simmo Mine still say pending validation and are acting strangely. The interesting piece you mentioned was the credentials. For some reason the dataflow will only work for my co-worker, even though my IT department has given me the same access to the datasources and gateway. They will refresh now that he took control but we still can't explain why it won't work for my profile.

Frequent Visitor

Dear Team,

@fffdk @sfbind2 @manutremo @Simmo @xcentricdave 

why this Pending Validation Shows in Table type. is there any issue in near future? 

#dataflow  Help @myMicrosoft 

Datafloe pending .png

Frequent Visitor

I am also experiencing very long wait times on dataflow query validation; I was under the impression that MS had changed this earlier in the year so that validation occured in the background, allowing you to continue working - however I had several attempts yesterday to update 3 tables in a dataflow, the longest in excess of 3 hours without result. I cancelled and restarted it at 21:30 UTC and it completed overnight at some point.


This is a ridiculous situation for MS to put it's users in without acknowledging the issue or trying to actively resolve it.

Helper I

Following as well, all of my flows are showing pending as well, fails auto-refresh but passes manual refresh.  Just started happening within the last week.  Same error as most: 

Error: Data source credentials are missing or invalid. Please update the credentials for SharePoint in dataflows settings page and try again. [Path:]. Request ID: cd8e819e-2ffc-479d-98b7-d768fa0bea28 Activity ID: c30ecc54-f5bf-443d-b630-8163405deac2


I will add that I can make changes, create new flows and it saves just fine with passing refresh, so I'm different in that aspect as some of the other comments.

New Member

I am in a permium workspace and having same issue. Cannot get my dataflows updated as required- all 'pending validation'

Regular Visitor

So, unfortunately this is one issue that turned out to be bad timing. I repeated the steps to create this with MS support and it worked flawlessly. And it has been working for me since.

Regular Visitor

"I repeated the steps to create this with MS support and it worked flawlessly. And it has been working for me since."


Can you clarify what you mean here? What were you recreating?