Showing results for 
Search instead for 
Did you mean: 

Dataflows - No entity after refresh

Hi, ,


I am having issues with a dataflow today. I have made some changes to it earlier today and since then it is not returning any entity. During the preview, it is showing correct data but no data is shown when I connect it through Power BI Desktop. The Power BI Desktop query is not showing any entity. 


This may be linked to the following issues already on the Power BI Support Page


Customers creating a new Dataflow from the Power BI service will see the default setting "Allow combining data from multiple sources" set to true instead of false. As a workaround, customers can uncheck the setting. Engineers are working on a fix and expect it to be deployed by end-of-day 11/22/2019.




Status: Accepted
Community Support

Hi all, 


The same issue has been reported internally: CRI 159107800. ETA for fix is end of week.


Best Regards,
Qiuyun Yu

Community Support
Status changed to: Accepted
Frequent Visitor

Same issue.

Fixed using @anselmojg's technique - changing dates to datetime using advanced editor (i couldnt find a way to change datatypes in Edit Entities GUI in service - was i missing something???)

Thanks @anselmojg  you saved my bacon yesterday

Regular Visitor

I ran into a similar issue yesterday, where a table would look like it refreshed properly, but wouldn't show up as an entity under the dataflow. The problem for me turned out to be if I had a column that was marked as a date instead of as a datetime. I went into Power Query within the dataflow and changed the datatype for that column (by clicking the little calendar icon at the top of the column) and choosing datetime instead of date. Refresh table. Everything worked as expected.


I didn't really see any kind of error that led me to this. But what tipped me off was that when I clicked on the entity to show the fields and the data types of each field in the entity, the date columns were saying Unrecognized (I think that's the word that was used) instead of date or datetime. After changing the data type to datetime, everything worked.


Good luck!

Regular Visitor

Hi all,


I believe this is two issues:


1 - Some Dataflows don't appear at all (this is because they contain a date column, so convert the date to text as a short term fix)


2 - Some Dataflow tables appear as empty inexplicably. I haven't gotten to the bottom of this yet and it doesn't make much sense to me, I am loading several dataflows in the exact same way and some appear as empty, some don't. Going to contact support.

Frequent Visitor

datetime also worked for me so far, working on other tables now.  

Regular Visitor

We have the same problem and we are very urgent, after a week, that this big problem be fixed.
We have succeeded about Dataflows that we already had created and that we modified in some way, creating some new entity or modifying an existing one.
Thanks a lot


Nosotros tenemos el mismo problema y nos es muy urgente, después de una semana, que se arregle este gran problema.

Nos ha sucedido sobre Dataflows que ya teníamos creados y que modificamos de alguna forma, creando alguna entidad nueva o modificando alguna existente.

Muchas gracias,

Not applicable

@v-qiuyu-msft  Hey Qiuyu, Has the problem been solved yet?? My sitution is SQL source data is fine, but URL Odata sourse file is empty. (sources file to dataflow)

Regular Visitor

Any update on this issue from Microsoft?

Advocate IV



Any updates on this issue? Just has another dataflows not working