Showing results for 
Search instead for 
Did you mean: 

Dataflow refresh error Date/Datetime

Started getting this error on an old dataflow as of 14-Jun-2021. No changes made.


Error: Expression.Error: We cannot apply operator < to types Date and DateTime.

Operator = <

Left = 5/1/2020 12:00:00 AM

Right = 9/30/2020 11:59:59 PM



Status: New
Regular Visitor

Same here!

Community Support
Advocate I


Thanks, but the problem is not the same. Both values are already datetime as can be seen from the error message. However, for some reason the dataflow sees one as a date, whereas Desktop runs the query just fine.

Regular Visitor

I am also getting the same error in dataflows, also only since 14-Jun-2021; the same dataflows have refreshed successfuly previously. The refresh failures are arising from linked entities. All fields are already formatted as type date so there should be no error. Re-confirming the field format as type date in the query step before the one which creates the error seems to fix the problem - but this should not be necessary.

Frequent Visitor

We are experiencing a similar error with dataflows that were running before. Our is: Error: Expression.Error: We cannot convert the value #datetime(2019 9 26 0 0 0) to type Date. ..

Frequent Visitor

Same issue.  ihave raised a support ticket, will report back here.

possibly related to a recent service outage

Not applicable

Yep same issue here! How annoying!

Advocate I

The only workaround for me was to branch the query into a separate dataflow, which ran without a hitch.


Wrapping the columns into DateTime.From() or re-applying Transform.ColumnTypes() did not work with the original linked entity, but referencing the same entity in another dataflow worked.

Frequent Visitor

Still working with MS on solution.  We're seeing this issue with downstream dataflows using linked entities,  we've found that if you diable the load on the linked entities things refresh fine,  this isn't feasible for us though - would mean sheduling all dataflows.

We've had this problem before in 2020

Regular Visitor

I'm seeing this same issue also. Dataflow had been working fine for months and then started failing on 6/11/21. I thought I somehow inadvertently change something with it when looking at it the other day, so I went back and started from scratch, building everything step by step and confirming data along the way. Even with two date-typed columns, I get the reported error. Everything loads (and compares) fine in the preview screen.