Showing results for 
Search instead for 
Did you mean: 

Dataflow error - Unable to create new Dataflow or edit/update existing dataflow

I have attached the error screenshot, getting in all the workspaces, premium capacity as well as non-capacity. When I try to create New dataflow or edit the existing dataflow, unble to go to next option showing error on the page " refused to connect".

It was working fine 3-4 days back.








Status: New
Resolver I

Having the same issue

Community Support


I have tested on my side, it works well.

if you could use another browser to have a try、


Check if it is a cert related issues. Could you navigate to in the browser? Under regular circumstances it should show a blank page with no errors, but if the browser complains then it might be a certificate related issue.




Super User I



I tried the link " " , also I have raised incident/support ticket to the team for this issue.


Nothing is coming, blank window.



Advocate V

Same issue here


Using Premium and trying to edit any of my dataflows I get the message: refused to connect.




Frequent Visitor

Getting the same error:  " refused to connect" for all dataflows in our tenant when I attempt to edit the dataflows.  No premium. 


Dataflow refreshes are also failing intermittently, and never on the same entities.


This has been going on for several days for my org.


Edit:  I have tried in multiple browsers, logging out of the Power BI service and logging back in, clearing my browser's cache, and outright restarting my PC.  None worked.

Super User II

Hey folks, @mhossain @Davelli0331 @RyanBentham @v-lili6-msft @jbirco @
this is a bug. Fix is to replace the "www"-part of the URL with "app". 


For more details, check out my blogpost: Fix error " refused to connect" in Power BI dataflows (thebiccountant...


Frequent Visitor

@ImkeF Thanks so much!  That workaround allowed me to get back into my dataflows.  I'd wondered why I was getting so many CORS errors in my developer tools.


Will report back if this fixes my intermittent data refreshes as well.


Edit:  My dataflows seem to be consistently refreshing again.  Not sure if it's the URL fix from @ImkeF or coincidence but either way I'm glad.

Super User I



Thank you so much, seems it is working.  Read your blog too, very helpful

Advocate V
Regular Visitor

I had the same issue, I was using Google Chrome.
With Microsoft Edge it is working.