cancel
Showing results for 
Search instead for 
Did you mean: 

Data refresh through PBI Gateway keep prompting credential missing incorrectly

While using PBI Service with on-premise data gateway connecting local excel files, the refresh keeps failed with "credentialMissing" error, however all credentials has already been given and verified (with a green tick next to the each data source shown under gateway connection), nothing can do......

Screenshot_30.png

InkedScreenshot_29_LI.jpg

Status: New
Comments
Regular Visitor

We had a call with Microsoft Support Engineer. He suggested that the error is due to the use of merge or append steps in the Power Query when connecting to shared folder. He provided us with the below workarounds:

  1. Use Personal gateway
  2. Use Gateway for each file
  3. Try to remodel to avoid merge and append steps
  4. Move the files to Sharepoint or Onedrive

We have not yet implemented any of the workarounds.

Frequent Visitor

@HemantNagar  MS Engineer gave the same workaound to us, we are on Premium Gateway, we cannot use personal gateway also moving folder source to file is a not possible at all, we have report where we import 1000+ Uber daily trip files, do MS excpect me to create 1000+ individual excel tables and then merge them.

 

I have forwarded this issue to the Account Manager now.

Regular Visitor

We had all of these issues and "magically" they all resolved themselves this AM.  We deleted the "file level" access on the Gateway and returned to the folder level and all is working. 

Frequent Visitor

The issue resolved for me as well after having a call with the MS support. In my case the issue was related to how we set the file based data sources in desktop and how we define the connection in the gateway. In our earlier reports whenever we need to point to a file as source, we had to point to the file source in the desktop and than also add the same file to the gateway. I believe maybe last year, we noticed that the option of setting up a folder was added to gateway. We than created this folder as a gateway while keeping the sources in the reports pointing to files in this folder. And we have been running this way since than.  I believe whatever the last changes that were introduced, sort of closed that loophole (if you will) and started to fail the refreshes. 

 

The fix was to go into the report and update the source to point thru the folder. Here is link https://docs.microsoft.com/en-us/power-bi/transform-model/desktop-combine-binaries that might explain this even if you are not necessarily combining files. 

 

Regular Visitor

Nice update @mshipley002 !  Thank you.

 

I tested with my 'test report' and folder access 'missing' credential issue seems resolved.  Presumably via online service update as we did not update desktop or gateway components.  Fingers crossed this works for all our problem reports.  Cheers

Frequent Visitor

All our reports that were failing are now refreshing with no issues! We did update the Gateway but reading other comments it sounds like Microsoft must have applied a fix.  Just glad to be up and running again!

Regular Visitor

This was fixed for me as of 9/01 but suddenly again I am receiving the same issue on the same report as of 9/21. Is anyone else having this issue as well? 

Frequent Visitor

@brandonstrange  our issues have not returned but just wondering, did you download the September update?

Regular Visitor

@mlucking I have not. I am actually currently running the July 2020 version, and have been for the past few months. Our organization is a little slow to update ususally, but I will push back and see if I can get an update to our software and see if that helps!

Frequent Visitor

@brandonstrange I'm not sure if it will help.  I was on the August version, had issues which then resolved earlier this month. I noticed yesterday I automatically now have the September version and mentioned to a colleague i hope the refresh issue didn't return as a result.  I have not seen an issue yet but will post if i do.