cancel
Showing results for 
Search instead for 
Did you mean: 
0

Data Usage Metrics not updating and cannot view the dataset

Hi All - the admin account which I have access to is the owner of all datasets within our PowerBI service. However, since viewing usage metrics about 3months ago, the usage metrics are not refreshing, neither am I able to view the datasets in the 'Settings' page of the datasets. These two solutions (being assigned owner and removal of the 'old' datasets for the usage metrics) appear to be the suggested resolution route for this however I am getting nowhere.

 

I can use old metrics for the purposes of what I need to do, however have a preference for newer ones!

 

Am I missing something?

 

Thank you!

Status: Delivered

Hi,

Sorry for the late responding. I have moved to the Power BI Phone Team right now but I received the notification email from you.

 

According to the latest comment in the ICM, deleting the dataset using Rest API and recreated the Usage metric report resolves this incident. Here’s the steps mentioned in the official document:

https://docs.microsoft.com/en-us/power-bi/collaborate-share/service-modern-usage-metrics#delete-the-...

 

Thank you very much!

 

Best Regards,

Community Support Team _Robert Qin

Comments
v-robertq-msft
Community Support
Status changed to: Accepted

Hi,

According to my research, there seems to be a similar issue be reported internally, so stay tuned.

 

Problem description: The user is not able to see updated usage metric report for workspace. The report shows an error that "Usage data is outdated. Check the refresh history and data source credentials in the Usage Metrics Report dataset settings.". However, there is no Usage metric report dataset for that particular workspace, though the usage metric report dataset should be available. And also, the user is not able to save a copy of the usage metric report. The user is the admin for the workspace.

ICM: 285681155

 

In the latest update of this ICM, the engineers are still investigating this issue.

 

I will update here once I get any information.

 

Thank you very much!

 

Best Regards,

Community Support Team _Robert Qin

dhronw
Regular Visitor

Thanks for the info @v-robertq-msft! I'm currently experiencing the same issue, so I'm glad it's under investigation. 🙂

dhronw
Regular Visitor

Hi @v-robertq-msft, any update on this issue? It has persisted for almost a month at this point. Thank you. 

hkristiaNGD
Regular Visitor

@v-robertq-msft Is the engineers still investigating this issue?

v-robertq-msft
Community Support
Status changed to: Delivered

Hi,

Sorry for the late responding. I have moved to the Power BI Phone Team right now but I received the notification email from you.

 

According to the latest comment in the ICM, deleting the dataset using Rest API and recreated the Usage metric report resolves this incident. Here’s the steps mentioned in the official document:

https://docs.microsoft.com/en-us/power-bi/collaborate-share/service-modern-usage-metrics#delete-the-...

 

Thank you very much!

 

Best Regards,

Community Support Team _Robert Qin

dhronw
Regular Visitor

Awesome, I can confirm this works. I didn't see the dataset in the list in the workspace datasets tab, but was able to get an ID through the API Get Datasets In Group call

Prima_
Frequent Visitor

Hi,

I am also facing the same issue. Not able to view the dataset for the Usage Metrics Report. I was asked to delete the dataset from the workspace and try again. But, I am not able to delete. How to call the DELETE Rest API from Power BI Service? I don't see this screen with Try It option or the Screen on the Right with Run button. 

Prima__0-1657186571792.png

Any help is greatly appreciated. 

 

Thanks.

dhronw
Regular Visitor

Hi @Prima_,

 

Microsoft removed the 'Try It' feature, so you'll have to call the API another way like using python or maybe a GUI API testing software like Insomnia.

Prima_
Frequent Visitor

Noted @dhronw. Thank you.