Showing results for 
Search instead for 
Did you mean: 

Data Flows error when validating queries

I have two dataflows that have been working for months and still refresh successfully. The issue I have is that when editing either of them now, then clicking save and close, I get an error message saying 'An error occurred whilst validating your queries' after a few minutes.  This even happens when making no changes at all to the existing data flow and just clicking 'Save and Close', suggesting that either...

  1. the validation process has changed since this was last done successfully 
  2. there is a wider problem impacting both dataflows 

I am able to see a preview of all tables before with no errors before clicking Save and Close so can't narrow it down to any issue with a particular table. This means I can't edit develop either data flow beyond their current state and seems too much of a coincedence that both are experiencing the same issue all of a sudden. 


The fact this error occurs so quickly seems to suggest it isn't a memory issue.


Has anyone experienced this issue too recently?



Status: New
Community Support


Unfortunately, I can’t reproduce the same issue as yours.

According to my test, I can normally edit and save&close a dataflow:





Best Regards,

Community Support Team _Robert Qin

Regular Visitor

+1 Same here. Til today I'm still facing similar issue.

1. Tried refreshing the dataflow>> no error, then open the edit window, without editing click "Save & close" then error message
2. Then tried to edit the query of the dataflow>> preview of dataflow all ok BUT once "Save & Close" clicked then start validating queries then not long after error message appears.


Tried numerous time still the same issue. Even tried doing the same query step by creating new dataflow. Can't proceed to "Save & Close"

Either of this 2 error message will appear no matter how many times I tried.