cancel
Showing results for 
Search instead for 
Did you mean: 

Custom visuals have been disabled for your organization

In a Power BI embedded (via azure workspace) I get the following error on some visuals:

"Custom visuals have been disabled for your organization"

The visuals are not custom visuals from the custom visual gallery but very simple standard visuals, for example a standard Card visual to display a string, referring to a measure with a simple IF statement to choose between two strings.

A common element to all the places where I see this bug is the use of IF statement in the measure that is displayed in the visual.

In all cases the visual is a simple Card.

 

Status: New
Comments
ClausK
New Member

I have the same problem in PBI Embedded, but same reports in PBI Desktop work fine.

Within a report, those visuals which use custom visuals show the error message "Custom visuals have been disabled for your organization". Within the same report, visuals which use standard (non-custom) visuals don't show errors but correct data.

We did not actively disable custom visuals in our organisation (to be honest: I do not even know how to do that...)

All related reports use an Azure SQL Server as underlying data source.

plillevold
Regular Visitor

We are experiencing the same issue: no changes to our reports on our end, using custom visuals downloaded from the "Store" in PBI Desktop, such as Timeline Slicer.

We have engaged Microsoft Support on the Azure service, to investigate.

donquijote
Advocate IV

Thanks for any update on this issue!!

Honestly I start to feel quite fragile using Power BI embedded given how oftern these bugs slip into prod in the Power BI service without being able to do anything in our side to fix...

 

plillevold
Regular Visitor

I agree, we are feeling the same pain. I'm sad to say, of all the services we are consuming in Azure, none of them have the level of instability that Power BI has. 

 

Note to this issue: the same reports, when uploaded and rendered in powerbi.com, they work fine.

To your point  @donquijote, I cannot say that all our custom visuals are backed by IF measures, it looks more like it is a general issue for any custom visual.

tzvikei
Microsoft

Some customers in west Europe using Power BI workspace collection will not be able to display custom visuals. This is an issue with Power BI on workspace collection only. Power BI Embedded, PowerBI.com service, and Publish to web are all working fine. Engineers are aware of the issue and are working on a fix.

 

see https://powerbi.microsoft.com/en-us/support/

 

Tzvi Keisar

Program Manager

Power BI

tzvikei
Microsoft

The issue is now fixed.

Can you please verify?

 

Thanks,

Tzvi

 

plillevold
Regular Visitor

Can confirm that we're back and custom visuals rendering are working as expected.

tzvikei
Microsoft

Great, thanks!

tzvikei
Microsoft

As a side note, please consider migrating to the new Power BI Embedded solution, as the workspace collection solution is on a deprecation path.

https://docs.microsoft.com/en-us/power-bi/developer/migrate-from-powerbi-embedded


Thanks,

Tzvi Keisar

Program Manager

Power BI

plillevold
Regular Visitor

@tzvikei yes, we are actually running v1 and v2 "side-by-side" in our solutions, though we are holding back on going to production with v2 due to an outstanding issue with datasets being cached incorrectly.