cancel
Showing results for 
Search instead for 
Did you mean: 

Custom data colors reverting to default colors in the service.

We have published reports with custom data colors on the bar charts.  As of early last week, these custom colors were showing as desired online.  At the end of April, however, they all started showing default colors instead.  In the desktop files we see the custom colors, but in the service they are the default colors, even when re-publishing.  If I try and edit the colors in the service, the color picker just forces the default color.
Status: Needs Info
Comments
hitzand
Advocate II

Additional info: This occurs only on bar-type charts, and only when there is a single value being reported.  It occurs on new or existing reports, regardless of the data source type.

Anonymous
Not applicable

This is the same for me. All the colors revert to the standard color. This renders the created dashboards completely useless.

 

Please fix this, this is a big issue!

v-haibl-msft
Microsoft

@hitzand @Anonymous

 

I tried with several times but cannot repro the same issue on my side. If issue persists, could you please record a repro video and share with me? Fiddler traces are also needed to be collected during repro the issue and shared.

 

Best Regards,
Herbert

Vicky_Song
Impactful Individual
Status changed to: Needs Info
 
Anonymous
Not applicable

Thanks for the response. How can I include the required files?

v-haibl-msft
Microsoft

@Anonymous

 

You can upload them to online file service like OneDrive and then share.

 

Best Regards,
Herbert

hitzand
Advocate II

@v-haibl-msft

 

As you can see below, the custom colors are retained if there are more than 1 values, but reverted to default in the service if there is just one value:

 

Desktop

PowerBI-CustomColorsInDesktop.png

 

Service

PowerBI-CustomColorsInService.png

hitzand
Advocate II

@v-haibl-msft  I can't do a video or fiddler at the moment, but the PBIX, system info, and trace files can be viewed here.

Anonymous
Not applicable

@v-haibl-msft@hitzandYou can find a screenshot here. I'm not able to record fiddler at the moment.

Anonymous
Not applicable

@hitzand@v-haibl-msftI can confirm this issue occurs when published with one value.

As an additional issue it is now also not possible to use a color other than the standard color (with a single value) in Power BI desktop with the latest update.

 

I have created a workaround by adding a dummy value in order to use more than one value.