cancel
Showing results for 
Search instead for 
Did you mean: 

Custom Visual not visible in Power BI Apps

Hi,

When I publish a report containing Custom Visuals into a Power BI Apps, the custom visuals are not displayed. The rest of the report is ok.

For the moment I found this behaviour with the visuals "WordCloud" and "Text Filter". Those are the only two custom visuals that I'm using in my report.

 

001.jpg

 

There is a workaround which is first opening a report in the workspace containing this visual and then go back to the Power BI Apps. Then the visual works fine. For sure this workaround is not a solution because most of the users that will access the Power BI Apps won't have access to the workspace.

Status: Needs Info
Comments
Microsoft

Hi @aralai,

 

Could you please provide more details? It seems fine in my test.

Custom_Visual_not_visible_in_Power_BI_Apps

 

 

Best Regards,

Dale

Established Member
Status changed to: Needs Info
 
Regular Visitor

Same issue for me.

All the custom visuals included in my reports are not displaying in published apps.

The workaround proposed by @aralai is working fine but I agree that the purpose of app is not to be forced to go first in the workspace.

Actually this issue is not easy to find as the creator of the report do not have the issue. Only the people with which the app is shared have this issue.

 

It's really annoying. Published app are great but if you can't share your reports if they are including custom visuals, it's a mess. This needs to be fixed quickly or there is no use of having the app publishing option in PBI Service.

 

 

Frequent Visitor

Our custom visual does not work either. So this is a relevant bug!