Showing results for 
Search instead for 
Did you mean: 

Constant internal error or 401 error when refreshing Google Analytics data

Every time I try to refresh a .pbix dataset, I run into one of the following errors:

  • GoogleAnalytics: Request failed (401): Invalid Credentials Table: [Table Name]
  • There was an internal error.. The exception was raised by the IDataReader interface. Table: [Table Name]
  • There was an internal error. Table: [Table Name]

They seem to cycle through, even if I'm not making any changes. This is despite the fact that I've ensured my credentials are correct for the Google Analytics data source in the .pbix file, and under datasets>data source credentials. There's no problem refreshing through desktop, and I'm using an on-premise gateway to connect.


Here's a post I made in the community form, for a bit more detail

Status: Needs Info
Frequent Visitor

Hey Everyone,


I've been trying to get auto refresh set up on the web app, and I've been running into the following error message:


Message:GoogleAnalytics: Request failed (401): Invalid Credentials Table: [Table Name].
Activity ID:ee4d5395-0022-4f5d-83e3-937e5d62f328
Request ID:f968a2f6-b0a6-37f6-3dd4-0b2ae792740e
Time:2017-12-03 23:07:40Z


The error message is pretty clear—something is wrong with credentials. However, I've double checked all my credentials including:

  • Credentials on the desktop app (through data source settings) are correct
  • Credentials on the web app (under datasets>dataset credentials) are correct and match those on the desktop app
  • Not sure if related, but i've seen some other threads saying that the login on my browser might need to match to make sure things work, I've checked this as well

Refreshing data locally works just fine, so I'm surprised to get this issue on the web app.


I'm running an on-premise gateway on my computer, which is connected with no problem—I've tried refreshing it, and still run into the same problem.


Anyone have any ideas on how I could further troubleshoot?


Thanks in advance!

- C

Community Support Team

Hi @carlito,


The Google Analytics connector relies on the Google Analytics API. All the limits are from the Google side. Though the error message points to the credentials. I'm afraid the root cause is that the data model breaks the limits.


Please create a new simple model to troubleshoot. I guess no error will occur. Please refer to this document.


If this can't sovle your issue, please provide a Fiddler trace. I will try to help.


IMPORTANT: mask the confidential info first and send me a private message.


Simple guide to use Fiddler.

1) Close other tabs of browser except Power BI Service.

2) Open Fiddler.

3) Set tracing Https.

4) Use Power BI Service, such as open report, refresh tab.

5) Save sessions.



Best Regards,


Community Support Team

Hi @carlito,


1. The Google Analytics don't need a gateway. Please set it "connect directly".


2. Could be a workaround: change the password and the Power BI will ask for the new password.

3. Please refer to this post, could be helpful. 

4. This issue could be impossible to reproduce. So please provide the Fiddler trace if possible.



1. Did you have these error messages at a time?

2. Did the table appeared in the error message exist?


Best Regards,


Established Member
Status changed to: Needs Info