cancel
Showing results for 
Search instead for 
Did you mean: 
0

Connecting to Azure Analysis Services - but Fiddler "fixes" the problem ?

I'm working on a corporate network, and all internet access is routed via a proxy server.

When trying to connect to Azure Analysis Services with a particular prepared .pbix file, it fails with the following error

Resolution of actual cluster endpoint of Azure Analysis Server: 'asazure://northeurope.asazure.windows.net/xxxxxxxx' failed. Response from server: .
Technical Details:
RootActivityId:
Date (UTC):


So I installed Fiddler to try and troubleshoot. But with Fiddler running, then the problem goes away and the data loads fine. Obviously this is not a solution! Any ideas how to troibleshoot this one?


Also note I am a Power BI Pro user, but I couln't find any way on the web site to submit a support ticket. I don;t have O365 admin access. I'm sure I was able to submmit a ticket previously, but can't find the way now, don't know if the site has recently changed?

Many thanks.

Status: Delivered
Comments
Visitor

Make sure you have PowerBI March 2017 or above installed.

 

Then clear out any cached credentials by navigating here:

 

C:\Users\<your username>\AppData\Local\AADCacheOM 

and deleting all files - or at least those that appear relevant. You should then be prompted to reauthenticate again.

 

 

Frequent Visitor

I have found two more important things with this issue:

 

1 - The problem also affects conncections from MS Excel to Azure Analysis Services, not just Power BI, so it is probably a bug with the AS client.

 

2 - The problem occurs when using any kind of automatic config proxy.pac file. If you disable the "Use automatic configuratoin script" option in your IE settings, and just specify the proxy server directly, then the connection works fine.

Moderator

Hi @Simon_London_99,

 

Regarding this issue, I would suggest you create a support ticket follow the steps in below GIF.

 

Support Ticket.gif

 

Best Regards,
Qiuyun Yu

Established Member
Status changed to: Delivered
 
Visitor

 Was there a resolution to this?  We are experiencing the same issue.

Frequent Visitor

There is a bug with PBIDT and the MS Office ADO client drivers.

 

If you are using a .pac file in your browser configuration you cannot connect to the AAS. The simple workaround is not to use the .pac file in your browser.

 

The bug was fixed in the June release of PBIDT, but is still present in Office 365. There is an updated ADO client driver available, but is tricky to install this and get it working with MSOffice (we're using O365 click-to-run install), as it requires editing the registry. So we are waiting for O365 to be updated.

 

Hope this helps.

Visitor

Thanks!  Do you know which specific version of the Office ADO driver contains the fix (or have a link?)?  We aren't actually on O365 yet, so I'm wondering if we'll be able to get a driver in place that will allow Excel 2013/2016 to connect out to Azure AS.