cancel
Showing results for 
Search instead for 
Did you mean: 

Connect PBI to Tabular live query

Hi, 

 

I created and tested tabular model in VS without any roles. I connected to PBI desktop and created simple report. I created gateway and successfully connected using service account (admin in SSAS) to SSAS. 

Report was successfully uploaded to service and but then I got error. 

First error was  "User does not have access to the db or db does not exists" so i created role in ssms and added user with read permissions. 

After deploy I got error: It seems user has permissions, but something else went wrong. 

 image.png

I checked some tutorials how to use PBI with SSAS but with no luck.

 

Thanks, 

A

 

 

 

Status: New
Comments
Community Support Team

Hi @ALdo,

 

Did you map the user to a proper account? Please refer to service-gateway-enterprise-manage-ssas#manual-user-name-re-mapping.

 

Best Regards,

Dale

Visitor

Hi Dale, 

 

Yes, I did. Im logged into PBI service with aldo@boston.com user. When I run whoami /upn on my machine I get aldo@seattle.com. I made mapping from @boston to @settle. That mapping should be OK according to link you sent. I still get the same error.

Should I use Effective user name or Customdata option here?

 

gateway.pngupn mapping

 

BR,

Aldo

Visitor

I looked into the gateway log and found this error message:

atewayPipelineErrorCode=DM_GWPipeline_UnknownError
ProviderName=MSOLAP.5 --->
Inner exception chain: System.Runtime.InteropServices.COMException
<pi>System.Runtime.InteropServices.COMException (0x80040154): Retrieving the COM class factory for component with CLSID {308FF259-8671-4DF4-B66C-9851BFACF446} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).

 

Possible solution is reintall Office web components and that is last posible option for me now.

Does anybody know other fix?

 

BR, 
ALdo

Community Support Team

Hi @ALdo,

 

Please mask your private data.

 

Please try the following steps.

1. Try the option "Effective user names".

2. Does the second account have enough privilege?

3. Upgrade the Gateway to the latest version.

Connect_PBI_to_Tabular_live_query

 

Best Regards,

Dale

Visitor

Hi, 

 

Replaced user is in the role with read rights in tabular. That should be enought.

Im confused with this MSOLAP error. If user doesnot have enough privileges, i would expect different error.

 

Thanks, 

ALdo