cancel
Showing results for 
Search instead for 
Did you mean: 

Composite Models not working with RLS and custom data

Hi,

 

I have 1 Direct Query, 3 Import tables, and when I am trying to add custom data for example

 

let
Source = Table.FromRows(Json.Document(Binary.Decompress(Binary.FromText("i45WMlTSUYopNTAwTjY2UIrViVYyggtYQgSM4QKGFhARE4QeM1OwiClQBMjWVoqNBQA=", BinaryEncoding.Base64), Compression.Deflate)), let _t = ((type text) meta [Serialized.Text = true]) in type table [Value = _t, Metric = _t]),
#"Changed Type" = Table.TransformColumnTypes(Source,{{"Value", Int64.Type}, {"Metric", type text}})
in
#"Changed Type"

 

And published the report to service, and tried accessing with one of user who is assigned in my role. 

My report dispalys just the blank pages, like this...

With RLS.png

 

 

Actual Report should be dispalyed like this.

With Out RLS.png

This is just one tab, but the visuals in all the tabs are behaving the same way. 

 

This report works perfectly fine, when create a table in my database for these custom codes and load it as a table. 

 

 

Status: New
Comments
Moderator

Hi @yash1105,

 

As there are 1 Direct Query, 3 Import tables and 1 custom data table in your report, which table column do you use to define the RLS role? 

 

How do you share the report with another user, by adding the user as a member of the app workspace or via Share button? 

 

In Power BI service, please test as the role on your side to see if the same issue occurs. Also please ensure the user are running the same browser to view report as you. 

 

Best Regards,
Qiuyun Yu 

Member

@v-qiuyu-msft

Role is created on the table with Direct query.

My Direct query has just 3 columns

Email, Order#, Client#

 

We are not using apps, and no users have access to workspace.

We share just the report and add the person to role or a AD group. 

 

After a test user raised the concern, the screen shot provided in my query above is from "Test as the role" 

Moderator

Hi @yash1105,

 

I'm not able to reproduce the issue. Please update your Power BI desktop to the latest version 2.64.5285.741 then republish report to test again. If issue persists, I would suggest you create a support ticket to get dedicated support. 

 

Support Ticket.gif

 

Best Regards,
Qiuyun Yu 

Frequent Visitor

I have the same problem, but only when such report is published to a premium workspace.

When I publish the report to My Workspace then it works as it should (when testing "as role" and selecting different users with differnet roles, the report filtrs the data as it should).

Only when published to a premium workspace then it shows all tiles related to filtering by RLS as blank, that was tested by real users (with whom I shared the report) and also by "test as role". And my desktop application is the latest version 2.64.5285.741 (64bit)

 

Matus

Regular Visitor

Hi @yash1105 and @jgabalm 

 

Did you get a solution to this problem? We have a report that has several direct queries and 1 import and it was working fine in April 2019 and suddenly stopped working on 4 May 2019. I have a premier suppport call open and MS are looking into it. However I have just seen this thread and tried publishing my report to a non premium and it works.

 

So I have sent this information to my support engineer to aid them, but if you have a support number or a solution that would be useful too.

 

regards

Andrew

Member

@UOLandrewdale 

Instead of using enter data on power query, I have created tables in SQL Server with the hard-coded values. 
I am using those tables from SQL Server to make my report work late last year. 

After that, I have tried to go back to custom data.(Enter data)

Frequent Visitor

Hi @UOLandrewdale 

 

for me it was sorted out after an update (I think it was december or january update, I don't really remember which one) and it works fine ever since.

I have several reports created like this:

all tables in the report are imported only RLS table is direct query and I don't have any issues at the moment with RLS

Also all of my reports are published in premium workspace. 

 

BR

Matus

Regular Visitor

thanks both