cancel
Showing results for 
Search instead for 
Did you mean: 

Column Charts - Not showing properly once published

I have 2 column charts that are not showing properly once published. they are both appearing normal in the PBIX file but completely wrong on powerbi.com

 

powerbi.com

jdaily83_0-1623788941285.png

PBIX

jdaily83_1-1623788992012.png

 

Status: New
Comments
v-chuncz-msft
Community Support

@jdaily83 

 

I tried the latest version to publish a report and it seems to be working fine.

jdaily83
Frequent Visitor

@v-chuncz-msft I have the latest version

jdaily83_0-1623844075765.png

 

v-chuncz-msft
Community Support

@jdaily83 

 

I cannot reproduce it. Try to rename the file and publish it again.

jdaily83
Frequent Visitor

I had to recreate the file.. Renaming did not work

skasper
Advocate V

I have the same problem with ALL our reports and all kinds of visuals. The only difference is that the charts are not rendered correctly in PBI desktop (June Version), either.

@jdaily83 , when you say 'recreate', you mean you saved the PBI file under a different name or open a blank file and rebuild everything?

skasper
Advocate V

Follow-up:

It turns out that - for me - the problem was caused because there was no font-size value set for the 'legend' on charts.

The easiest way I found to fix it is to edit the current theme and define the font-size there (see below). As soon as this is done, the charts render correctly. Of course, I had to republish every single report (around 40 in total).

I want to point out, that these reports worked perfectly until June 21 (at least), and then ALL broke.

This makes me believe that it is related to the June PBI update.

NCD4YStDKw.png