cancel
Showing results for 
Search instead for 
Did you mean: 

Card with states visual - Data label issue

Does anyone facing the problem when using Card with States by OKViz?

 

The date label is not working after the cube refresh this morning. The color of data label should be red but it shows as green. This was working fine since Monday. I have read thru various issues report about this visual - we dont have text display issues for this but the data label color is mixed up

 

Do we need to change any settingStates setting.png

 

I am not sure what is causing this problem. Please do let me know as it's impact lot of users. 

 

Thansk,
Siva

Status: New
Comments
Frequent Visitor

Also, I noticed that latest version of card of states not available in the office store. The version available is 1.3.5 whereas OKViz enhanced the visual twice this month and fixed it. I am not sure whether latest version might help to fix my issue. 

 

Advocate III

I checked wiht the latest version 

 

cardWithStatesByOKViz-1.3.7B.pbiviz

 

The status is appearing but the bacground color which is based on the state value is still not appearing. 

 

Tyring to figure it out. If something changes will update here. 

Advocate III

Checked the example PBIX file and realized that the usage has changed. 

 

Whatever you were using to control the background color has to be now placed in the "States Measures" field has to be now moved into the "Measures" field. 

 

I basically use it to control the background color of a patch in the report and it helped when I made that change.

 

Earlier, it was not so and we could have background color controlled by a field in the "States Measures" and what appears in the box was decided by "Measures" now both are being managed by "Measures" so what you put in "Measures" parameter will decide the background color.  

Regular Visitor

There was a bug around rendering on States Measure, but OKViz has resolved it in version 1.3.8.

 

https://okviz.com/card-with-states/

Microsoft

@mark-awhere

 

Based on my test, it seems that the state color issue still persists in cardWithStatesByOKViz-1.3.8B as following screenshot.

Could you please check in on your side? If issue persists, are you able to reopen it in GitHub?

 

Card With State - No text displaying as of_1.jpg

 

Best Regards,
Herbert

Regular Visitor

@v-haibl-msft, I posted on the other thread before checking this one.  1.3.8B is working for me.  I think you need to adjust your comparison operator and state values.

 

state measure.png

Frequent Visitor

Hi Everyone,

 

Still I having issues with the measures as the states measures setting is causing problem and not consistent. I have updated to latest version 1.3.6 as in the store. We normally use the custom visuals from the store.

 

Any solutions yet??

 

Thanks,
Abi

Frequent Visitor

Hi Everyone,

 

Background color is not the problem for us. We have issues with variance and data label effects based on the states measure. Eventhough we have achieved the target, the color stays red and business is asking about this  everyday. Also, we dont use custom visuals other than from the store. Hopefully bug will be fixed soon.

 

Thanks,
Siva

Helper V

Problem still remains. No solution so far? This tool gives me the creeps. Why do we have "states" in the formatting pane when you cannot set the rules proberly?

 

Could someone please fix this?

Anonymous
Not applicable

Card with state visual shows the state when a selection is made but not at overall level