cancel
Showing results for 
Search instead for 
Did you mean: 
0

Card Browser Visual - Metadata Issue when connected to Power BI dataset

I recently discovered that the Card Browser visual does not allow changes to the "Metadata" fields when the report in question is connected to a separate Power BI dataset rather than a local model. This seems like an odd limitation of the card browser visual. To make a change to the metadata, I had to open two copies of my report, change one of them to Direct Query mode, modify the metadata then copy the visual back into the original report.

Status: Delivered

Hi @CoulterJames2 

The "Metadata" you mentioned is to change its column name or the value ? As we all know ,that if you connect to Power BI Dataset ,the connnection mode is Live connection , that means you cannot change the value in Desktop directly . We usually change data in data source if the connection mode is Live connection . So, it's not really a problem, you can't modify the source data directly in Live connection mode . But you can shange column name in visual . 

Ailsamsft_0-1652766095757.png

 

Best Regards,
Community Support Team _ Ailsa Tao

Comments
Ailsa-msft
Community Support
Status changed to: Delivered

Hi @CoulterJames2 

The "Metadata" you mentioned is to change its column name or the value ? As we all know ,that if you connect to Power BI Dataset ,the connnection mode is Live connection , that means you cannot change the value in Desktop directly . We usually change data in data source if the connection mode is Live connection . So, it's not really a problem, you can't modify the source data directly in Live connection mode . But you can shange column name in visual . 

Ailsamsft_0-1652766095757.png

 

Best Regards,
Community Support Team _ Ailsa Tao

CoulterJames2
Frequent Visitor

Hi @Ailsa-msft thanks for responding. Renaming fields is not the problem, the problem is not being able to change the metadata fields in the visual if my report is connected to Power BI dataset rather than a local dataset. Here's an example: when the visual and the data are in the same report, I can modify the metadata fields fine: 

CoulterJames2_2-1652775844845.png

 

Metadata: 

CoulterJames2_0-1652775481532.png

Now, I publish this report to Power BI, then create a new report using the dataset from this report, so I now have a live connection to the dataset.

I can copy/paste the visuals from the original report into the new report no problem:

CoulterJames2_1-1652775818813.png

The issue I had was that I was then unable to add a new field into the metadata section of the visual. When I tried to drag the field in, it was added into the "Badge (Image URL)" section above instead and could not be moved into the metadata section.

 

I have tried to reproduce the issue with a sample dataset but cannot now see the behaviour I described. But I do have an existing report in which this happens.