cancel
Showing results for 
Search instead for 
Did you mean: 

Cant use data from native query/direct query to plot graphs

Hello all,

 

I have an azure postgresql database which is direct query supported by powerbi. Anytime i run a native query(sql statement) to fetch the data it loads fine in the query editor and the table and its columns show in the visualisation pane. Now the problem is everytime i try to use the data to create any graph/table/slicer i get the following error:

 

DirectQuery error: DirectQuery may not be used with this data source - please consider moving to a supported data source or upgrading the SQL Server data sourc to the latest available version.

 

This doesnt make any sense to me, direct query already worked in the first place and i was able to load the data in the query editor and everything works fine, and then i get that error when i use the data to plot any graph?

 

When i tried loading a table using direct query but without the use of a native query i was able to plot graphs. I think the problem is the usage of the native query(sql statement) to fetch the data from the database.

 

I thought the sql statement was complex, but i ran a simple statement such as "SELECT * from table;" and i still got the same error. I would really appreciate some help.

 

Just to mention that this is happening in the PowerBI desktop.

Status: New
Comments
Community Support

@Adham 

 

That seems to work fine for me. You may try the latest version to recreate the report.

Helper III

@v-chuncz-msfti redownloaded powerbi desktop and it worked!