cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot delete dataset

I cannot delete a dataset from within a workspace.  I have tried suggestions in other posts including overwriting it with a new dataset, refreshing the page, clearing cache, etc.  No luck.  I have heard that microsoft can remove this for me.  How do I request that help?

 

details from error message are here:

Something went wrong
Please allow time for the dataset removal to be processed, and then try deleting the dataset again.
Please try again later or contact support. If you contact support, please provide these details.
Activity ID: 1f98b9e7-9b7a-4604-a3fa-05a7357fe65a
Request ID: 2af2d43a-b32c-7bf3-fe26-80b6abf35f9e
Correlation ID: 5b0efa4b-7f84-dd4d-49f2-03758cf3e2c0
Status code: 400
Time: Mon Dec 23 2019 16:58:02 GMT-0800 (Pacific Standard Time)
Service version: 13.0.11747.247
Client version: 1912.2.028
Cluster URI: https://wabi-west-us-redirect.analysis.windows.net/

Status: New
Comments
Community Support

Hi @KimberlyS

 

From internal trace, I found the error "the model must first be removed from the organizational app before it can be deleted."  Please go to the app workspace which contains this dataset, find reports or dashboards related to this dataset, turn off  "Included in App" option for them, click on Update App. After updating the app successfully, please delete the dataset again. 

 

Best Regards,
Qiuyun Yu 

Advocate I

Hi Kimberly

 

I had the same problem just before Christmas and was going to suggest what Qiuyun has posted as that worked for me.

Perhaps Microsoft could explain why the error that is presented to us, the users, is of no use whilst the internal trace error details exactly the issue and how to resolve it? Can we see the internal trace error somehow?

 

Dan P

Regular Visitor

It does have to do with the app, but I think it's like some metadata gets "stuck".  In my case, the dataset was not tied to any reports or dashboards anymore.  When I looked at the related content view, there was nothing there.  I had previously removed all of the reports and dashboards from the app and deleted them from the workspace.

 

However, the solution of republishing or unpublishing the app did allow me to remove the dataset.  It seems like in a few edge cases, the app still thinks the dataset should be included, even though there are no remaining reports or dashboards.

 

Now that I know,  it's not a big deal to just update the app one more time.  I don't like unpublish/republish because the app GUID changes, which breaks any browser bookmarks consumers have set up.

 

I agree with DanP, it would be ideal if the error displayed to end users gave us some idea of what to actually do to resolve the issue.

Community Support

Hi @KimberlyS

 

If you encounter the same issue next time, I would suggest you create a support ticket to get help and confirm if this is a bug or not. 

 

For your feedback about get detail error message, you can try to use Fiddler tool to capture trace. 

 

Best Regards,
Qiuyun Yu