cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot Sign in to a Sharepoint source using a Microsoft account. Sign in window does not open.

This was not a problem earlier and may seem to have appeared with the latest Power BI Desktop version.

 

After pressing "Sign-in" no sign-in window opens and everything hangs.

Vi12_1-1635232596840.png

 

I can get control back by pressing Alt+F4 (close window). Then I get this message:

Vi12_2-1635232933316.png

 

 

I tried to see what goes on in Task Manager while the sign in hangs. Power BI seems to try to open several Microsoft Webview 2 windows(2), May introduction of Webview 2 in Power BI be causing this?

Vi12_2-1635232398892.png

 

Status: Delivered

Hi @Vi12 

 

From July 2021 , infrastructure of Power BI Desktop started to be transitioned from using CefSharp to WebView2. According to official document Enabling Microsoft Edge (Chromium) for OAuth authentication in Power BI Desktop | Microsoft Docs, as of October of 2021, Power BI Desktop will use Microsoft Edge WebView2 for OAuth authentication for all connectors by default. When this happens, it is fully required to run Power BI Desktop. If it’s not already installed, please try to install the new Edge(Chromium) browser from https://www.microsoftedgeinsider.com/download or install the WebView2 redist package on your Power BI Desktop machine and then try your operation again.

 

Best Regards,

Community Support Team _Caiyun

Comments
JGroothedde
Frequent Visitor

Can you try turning off the 'Power BI Desktop Infrastructure Update' option in the Preview Features section of the options and settings? It's the last option in the list. This fixed the issue for me. Turning on that preview feature makes it so Power BI uses Webview instead of CefSharp. 

 

JGroothedde_0-1635235356320.png

 

Vi12
Frequent Visitor

@JGroothedde Thanks for the suggestion. I cannot do this however since our corporate setup requires Power BI Desktop to be updated from Microsoft Store. Apprently the option you mention is not avialable for the Store verion. I at least no not have that option availble in my latest availabel version of Power BI Desktop.

nabilrock
Regular Visitor

Hello guys,

Im having the same issue from yesterday.

could it be linked to the last update ?
 

JGroothedde
Frequent Visitor

@nabilrock Seems like it, yes. Reverting to the september version of Power BI and turning off the Preview Feature 'Power BI Desktop Infrastructure Update' solved this for me. Apparently turning off the preview feature is not possible in the October version, so it's best to revert back to the September Update.

Vi12
Frequent Visitor

@nabilrock The more people who experience this, the more tempting it is to have that as the main hypothesis, but honestly I do not know. Hopefully someone in the Power BI Desktop team can comment and clarify.  The only other alternative I have thought about is that something has changed with our corporate setup of M365.

RayRay44
New Member

I'm reporting the same issue: Lack of a login window after I updated my organization password using Office 365. No login window when updating my credentials and attempting to connect to Azure database.

v-cazheng-msft
Community Support
Status changed to: Delivered

Hi @Vi12 

 

From July 2021 , infrastructure of Power BI Desktop started to be transitioned from using CefSharp to WebView2. According to official document Enabling Microsoft Edge (Chromium) for OAuth authentication in Power BI Desktop | Microsoft Docs, as of October of 2021, Power BI Desktop will use Microsoft Edge WebView2 for OAuth authentication for all connectors by default. When this happens, it is fully required to run Power BI Desktop. If it’s not already installed, please try to install the new Edge(Chromium) browser from https://www.microsoftedgeinsider.com/download or install the WebView2 redist package on your Power BI Desktop machine and then try your operation again.

 

Best Regards,

Community Support Team _Caiyun

Vi12
Frequent Visitor

Hi @v-cazheng-msft 

Thank you for the response. I will try to get permission from our admin to make the two software updates and report back here whether this solved the issue.

JGroothedde
Frequent Visitor

Hi @v-cazheng-msft ,

 

Thanks for the response. I will also try this and report back whether this fixes the issue(s).

nabilrock
Regular Visitor

hi @v-cazheng-msft ,

 

I tried this and it didnt fix the issue, 

I Installed the last version of Edge and it didnt work.

I also installed the WebView2 package and it didnt fixe the issue.

 

Any idea ?

Thanks in advance,