cancel
Showing results for 
Search instead for 
Did you mean: 

Can't sign in to Register an App

Hi,

 

I've been having difficulty registering an app for a couple of days. When clicking sign in https://dev.powerbi.com/apps, I'm being directed to https://powerbi.microsoft.com/en-us/developers/ instead of proceeding to step 2. Appreciate any help on this.

 

Thanks,

Status: Investigating

Hi,

To register an APP, please refer to this official document to check if it can work:

https://docs.microsoft.com/en-us/power-bi/developer/embedded/register-app?tabs=customers%2CAzure

 

Thank you very much!

 

Best Regards,

Community Support Team _Robert Qin

Comments
v-robertq-msft
Community Support
Status changed to: Investigating

Hi,

To register an APP, please refer to this official document to check if it can work:

https://docs.microsoft.com/en-us/power-bi/developer/embedded/register-app?tabs=customers%2CAzure

 

Thank you very much!

 

Best Regards,

Community Support Team _Robert Qin

nandanu
New Member

Hi,

 

Any update on this? I'm still having the same issue reported by the OP.

 

I tried going the embedded route and got as far as getting the access token but when I run the query in Postman against an endpoint such as https://api.powerbi.com/v1.0/myorg/reports I keep getting a 403 Forbidden response.

 

I'm following the instructions as shown in How to access Power BI REST APIs programmatically (sqlshack.com)

 

Somewhere in SO I read that the reason is that endpoint requires an AAD access token rather than an embedded token.

 

Any help would be appreciated.

 

Thanks!

pcc18
Frequent Visitor

Hi @nandanu ,

 

I had luck on registering the app and token using embedded. I'm using MSAL and python to access the API. Used to get 403 response as well. I think you just need to grant admin access to your register app for every workpace - should just be the same as how you would grant a user access to a workspace. If you're using service principal, you also might want to check on the tenant developer settings if the use for PBI REST API is enabled. Hope this helps.

 

Thanks,

nandanu
New Member

Hi @pcc18 ,

 

Thanks for the quick response. I'll give it a try.

 

I'm not currently using a service principal but for now trying to get it to work with a user account.

 

My final objective is to run DAX queries on the Power BI dataset from a Power Automate flow. I wouls like to get it to first work in Postman so that I can then plug in the same process with access tokens etc. in the flow.

 

Thanks!