cancel
Showing results for 
Search instead for 
Did you mean: 

Can't refresh any datasets on BI online service

Yesterday, all my datasets were refreshing just fine but today nothing happens.

- The automatic refresh hasn't done anything.

- When I press "Refresh now", I get a "popup" saying "preparing refresh" for a split second and then nothing happens.

 

The only way to update the data is to refresh the Desktop version and then upload it. 

 

I have datasets connection to an on-premises database and one connecting to a sharepoint site.

- The on-premises connection usually works perfect, but now nothing happens.

- The sharepoint connection usually brings up an error,  if I try to refresh, but now nothing happens (I just tried it this time as a test, as it usually doesn't work automatically).

 

Can you please help troublefinding - It seems like an issue on you online portal somehow.

 

Thanks in advance.

 

// Tommy

Status: Delivered

Refreshes can fail for a whole bunch of reasons and given how critical refresh is to Power BI, we have created this article to help you trouble shoot: 

https://docs.microsoft.com/en-us/power-bi/refresh-troubleshooting-refresh-scenarios

Comments
New Member

alrightly then...still not working from the US

Frequent Visitor

This is now working again for me; refresh is for Project OnlIne out of SharePoint using OAuth2.  Mind you, I had to delete and republish my model from PBI Desktop.

Impactful Individual
Status changed to: Delivered
 
Regular Visitor

Still unable to refreseh or import the MailChimp Content Pack.  When will this problem be solved?  Is there a site to check the a timeline to resolution?

Frequent Visitor

Still unable to refresh SharePoin Online

Impactful Individual

Why does the support site say that there are no known problems when so many people cannot publish their reports ?

 

 

Frequent Visitor

I think I have the same problem trying to refresh from Sharepoint. Is there a solution for this? I get these specs:

 

Er is iets verkeerd gegaan.
 
Fout bij het configureren van het geselecteerde bestand
Probeer het later opnieuw of neem contact met de ondersteuning. Geef de volgende gegevens op wanneer u contact opneemt met de ondersteuning.
Activiteits-id45827d31-37bb-9c5b-07c1-93cdde1246b0
Aanvraag-ida4ec6a1d-609a-7c64-a437-14a48eeb35d5
Correlatie-id20d8d127-a8f7-a586-b926-c86aedbd38b5
Statuscode400
TijdMon Jan 30 2017 11:18:55 GMT+0100 (West-Europa (standaardtijd))
Versie13.0.1700.1082
Helper III

I was just trying to setup the sharepoint refresh, and getting similar error 400. Since this is first time setup, I'm not sure if its this issue, or an unrelated issue. 

 

Failed to update data source credentials.Hide details
Activity ID: 712e191c-29ab-4ae9-bc1e-5ccee5b8dec0
Request ID: 88f0f9a8-d842-995a-8021-918f53d3d041
Status code: 400
Time: Sat Feb 04 2017 19:59:29 GMT-0500 (Eastern Standard Time)
Version: 13.0.1700.1121
Cluster URI: https://wabi-us-north-central-redirect.analysis.windows.net

Frequent Visitor

When I take the root of the url (up to the file-name) and add the file-name to it NOT via the url-copy but by getting the file-name via the properties of the file, it turns out right.

 

New Member

We're having the same issue "https://community.powerbi.com/t5/Issues/OData-Feed-Failed-to-update-data-source-credentials/idi-p/10..."

 

I opened a ticket a month ago and I couldn't get anyone to deep dive into the issue.  This is frustrating!