Showing results for 
Search instead for 
Did you mean: 

Can't refresh any datasets on BI online service

Yesterday, all my datasets were refreshing just fine but today nothing happens.

- The automatic refresh hasn't done anything.

- When I press "Refresh now", I get a "popup" saying "preparing refresh" for a split second and then nothing happens.


The only way to update the data is to refresh the Desktop version and then upload it. 


I have datasets connection to an on-premises database and one connecting to a sharepoint site.

- The on-premises connection usually works perfect, but now nothing happens.

- The sharepoint connection usually brings up an error,  if I try to refresh, but now nothing happens (I just tried it this time as a test, as it usually doesn't work automatically).


Can you please help troublefinding - It seems like an issue on you online portal somehow.


Thanks in advance.


// Tommy

Status: Delivered
Frequent Visitor

It now seems that I can update the datasheet by clicking "refresh now".

Frequent Visitor

I can also confirm that my on demand and scheduled refreshes are now working.

Established Member

I still cannot update my dataset Smiley Sad

I have 8 OData API connections and 6 Web connections to OneDrive for Business Excel Files

First - it shows error "Can't refresh your data: The credentials you provided for the Data Source are invalid".

When I go to settings and enter the credentials in 3 places with "X" error mark next to them - it accepts them (I don't know why it shows this error in the first place).

Then - I press on Refresh now - and after showing "Prepare for refresh" for several seconds - nothing happens. I don't even see the "working circle" next to my dataset.

I just have to update in Destop and republish

The Microsoft Support Page now shows "No known issues..."

Please help...


Thank you


Frequent Visitor

I am still unable to refresh OData from MS Project Online; 


"The last refresh attempt failed because of an internal service error."


Cluster URI:
Activity ID: b95ad673-ba62-4da9-8091-ab423043569f
Request ID: 76e535fc-28eb-481f-8c93-6c150128de71
Time: 2017-01-19 22:03:01Z


Occurs both on-demand and when scheduled.


Frequent Visitor

Works again for me (in Gemany).

Established Member

still not working

pjn Frequent Visitor
Frequent Visitor

No joy from here in the UK. All our files are held in OneDrive for Business (CSVs apart from a single XLSX) and I'm seeing "An unknown error has occurred. Please try again later" message when checking the refresh history.


I'd also noticed that half our oAuth2 credentials had been lost (which I remedied) but still no joy.


Hopefully we'll see a more widespread fix soon.


EDIT: I've checked it again (7 hours later) and things seem to be working for me now. Will see how tomorrow's scheduled refresh goes, so fingers crossed.


Frequent Visitor

Any idea when this will be fixed again?

skeduled refresh is executed, but the charts are all empty. Same when I use "refresh now".


After publishing it via Power Bi Desktop it shows the data and after checking the skeduled refresh it was gone again.. Very strange! It looks like the service is refreshing immediately after the publish and then the data is gone again.


Please send an update about the progress and an estimation when it will be fixed.


Best, Jasper


Super Contributor



The original refresh issue has already been fixed. The known issue is not listed in the support site now. The refresh failure of your dataset may be caused by different reasons.


Best Regards,


Frequent Visitor

Thanks Herbert,


it seems that I have another issue too for one dashboard; something with prefixLength should be 1, 2 or 4..

Best regards, Jasper