cancel
Showing results for 
Search instead for 
Did you mean: 
0

Can't publish a report with Multiple data sources(MSSQL, Athena) - Erroring when I try to publish

marvinLee_0-1657057606743.png

 

Status: Delivered

Hi @marvinLee ,

 

Ensure that you've added both data sources to the gateway, as described in Add a data source. If the gateway doesn't appear in the admin portal under Manage gateways, clear your browser cache or sign out of the service and then sign back in.

The server and database must match exactly between the gateway data source and your report.

 

Best Regards,
Community Support Team _ Caitlyn

 

 

Comments
v-caitlyn-mstf
Community Support
Status changed to: Delivered

Hi @marvinLee ,

 

Ensure that you've added both data sources to the gateway, as described in Add a data source. If the gateway doesn't appear in the admin portal under Manage gateways, clear your browser cache or sign out of the service and then sign back in.

The server and database must match exactly between the gateway data source and your report.

 

Best Regards,
Community Support Team _ Caitlyn

 

 

jpsanabria
Frequent Visitor

The issue is probably DirectQuery. You cannot publish to web when a report uses more than one source, AKA DirectQuery. 

https://docs.microsoft.com/en-us/power-bi/connect-data/desktop-directquery-datasets-azure-analysis-s...

 

marvinLee
New Member

I am not sure how I can add Athena data source to existing PowerBI gateway. 

Anyone know how ? Try2CreateAthenaPoweBI-Gateway-2022-07-06-155253.png