Showing results for 
Search instead for 
Did you mean: 

Can't connect to Dataflows

After udpating the Power BI Desktop to April 2021 version, not able to connect to dataflows. Tried the laptop reboot, sign out and sign in. 


Below is the error message I get everytime. 



Status: New
Community Support



The latest version works fine for me. You may also try earlier versions from Power BI updates archive.


Regular Visitor

I am experiencing the exact same issue. 

Helper II

@v-chuncz-msft  This is an issue with the service. I already downgraded my client with no success. We use a GCC tenant. Based on the number of votes of the two "hot" issues, it's clear there is a problem. 

Regular Visitor

Same issues here in a GCC tenant. The solution that finally worked for me is I cleared all data source permissions while in the April release, uninstalled, and then reinstalled the March 2021 release. After that I was able to refresh from my dataflows again. 

Resolver IV

Even I had to uninstall the April 2021 release and then re-install the March 2021 release. 


Only after that I was able to work with my dataflows again. 


From the error message it looks like a .dll file of some kind is missing from the newly packaged release. 

Regular Visitor

I have only installed the april version after i discovered the error. I was hoping the old version was causing the issue. This does not seem to be the case. Clearing Data-Source privileges  didnt help either. 

Frequent Visitor

I have the same issue


unable connect to the right account, couldn't recognize the credential of account under

Advocate II

same here - what to do?