Showing results for 
Search instead for 
Did you mean: 

Can't change data source for Paginaged Report located on PBI portal after latest update



We have a local Power BI Reporting Portal (used to be Reporting Service) with lots of reports both PBI and Paginated.

After latest January Power BI Server Update we are not able to change the data source for Paginated reports. Changed are just not saved without any errors.


If report was published before - it is working fine, but can't change data sources.

If you upload new Paginated report - you can't set data source for it. It will always remain as not specified.

Status: New
Regular Visitor

We experience the same problem.


We went from version AUG 2018 to the newest version JAN 2019.


When we checked the data source it gives OK.




But when we start the Power BI reports it gives an error:

We couldn't run the report because we couldn't connect to its data source. The report or data source might not be configured correctly.
Please try again later or contact support. If you contact support, please provide these details.

We couldn't connect to the Analysis Services server. Make sure you've entered the connection string correctly.


The normal reports are working fine.


We add new reports and it gives the same error.



Community Support

Hi @laggerok19,


Based on my test with PBIRS January version, it's able to edit embedded data source connection string for .rdl report(SQL database) and save the change successfully. In your scenario, which data source does the report get data from? Please try to click on Ctrl + F5 to refresh Manage page then test it again. 



@Wanchai The issue you described is a little different from the initial post in this thread. As the issue is related to .pbix report, please open the report via Edit in Power BI desktop then check if the report renders fine in desktop. 


Best Regards,
Qiuyun Yu 

New Member

I can confirm the problem with three installtions of PowerBI Report Server

(Version 1.4.6960.38798 (January 2019)). Since the update im am unable to connect a rdl report to an existing  shared data source, i can successfully save the connecting to the shared data source, up on an website refresh the connection is gone. It only successfully saves a data source connection within the report.



Is there any better place to report the bug?


My workaround is directly updating the PBRS database:


use ReportServer


set =
case WHEN = 'Source 1' and link is null then (select cast(ItemID as nvarchar(max))from dbo.catalog where Path in ('/Data Sources/Source 1'))
WHEN = 'Source 2' and link is null then (select cast(ItemID as nvarchar(max))from dbo.catalog where Path in ('/Data Sources/Source 2'))

from DataSource ds

left join dbo.catalog as c
on ds.ItemID = c.ItemID




Frequent Visitor

This bug is reported also here: .




I cannot commit for PBX files and it doesn't matter in our case. If shared DSs for rdl reports are not working then no sence to do update.

Yes, in theory, we can override values in shared DS and replace them with embedded connection, but its ok way if you have 10 reports, but not an enterprise system with tonns of reports.


Regular Visitor

Hi Qiuyun Yu,



I forgot to mention that our reports make use of DirectQuery to a SQL database.


The .pbix reports are working fine in the desktop client. But in our production environment we do not have a desktop Power BI client. This workaround will not help the users and on the mobile app it is not possbile to open the desktop client.


I checked the response from CaWe and looked in the datasource table from the report server. I see there only the connections from the .rdl reports but none of the .pbix reports.


Do you have any other suggestions?



Frequent Visitor

They have fixed the issue silently (without any notification). Just take latest version.

New Member

Do you have a newer version than Version 1.4.6960.38798 (January 2019)? to lookup the version click on the ? in the top right corner.

Regular Visitor

Hi all,


The problem has been solved by updating the latest Version 1.4.6969.7395 (January 2019).

We had indeed Version 1.4.6960.38798 (January 2019).


Many thanks for the help and extra kudos for laggerok19.

And Microsoft many thanks for the new features.

New Member

 I can confirm that it works with the Version 1.4.6969.7395 released yesterday 🙂