cancel
Showing results for 
Search instead for 
Did you mean: 

Can't Publish or Save without Composite Model enabled - even with No M:M and all queries Imported

Had composite model preview turned on and was working in a model that only has imported queries had a M:M relationship created inadvertantly with a duplicate value in my Lookup Table. Noticed the problem when I tried to publish and I fixed the underlying issue in the lookup table and deleted and redefined the single M:M relationship in the data model to a 1:M and confirmed all my queries show as Imported. But I still cannot publish or open with the Composite Preview disabled. 

 

I tried following the suggestions in these posts but cannot get anything to enable me to fix this. 

https://community.powerbi.com/t5/Desktop/Composite-models-irreversible/m-p/481851#M224324

https://community.powerbi.com/t5/Issues/Unable-to-disable-Composite-models/idc-p/482033#M30066

 

I do have an older version fo the file but there are quite a few changes I made to the data model.  As you can see I have no BiDirectional or M:M relationships and I checked each of my queries say Imported. 

snip_20180817125138.png

 

 

Status: Needs Info
Comments
v-qiuyu-msft
Community Support

Hi @Seward12533,

 

Is it possible to share the pbix file with us? You can upload pbix file to your OneDrive, then send the link to me via private message if the report contains sensitive data. 

 

Best Regards,

Qiuyun Yu 

v-qiuyu-msft
Community Support
Status changed to: Needs Info
 
Seward12533
Solution Sage

Will a template work?  I will see if I can reproduce with a file I’ve used to help others in the desktop community forum.  But this file is a complex model with proprietary data. 

cbb4
Frequent Visitor

Did you ever figure out this issue? @Seward12533