Showing results for 
Search instead for 
Did you mean: 

Bug with slicer and Bookmark in Service

In the Power BI Service, I have uploaded a project that utilized a bookmark to reset several slicers on a page.  This works smoothly in Desktop, but in the service, it does not function reliably.  Is there a workaround for this, or is this a known issue?  


Using the standard drop down slicer and no custom visuals.  



Status: Accepted



I'm not ver sure what it worked but my bookmarks function correctly again Smiley Happy


Thanks RELJack, I considered your comments. Once I installed the February version of Power BI Desktop, I opened my original file and I kept my bookmarks created. Then, I updated them using the right click menu in the Bookmarks pane (no matter if they didn't have any modification). Also, the buttons were linked again to their respective bookmarks. Finally, I published again my report in the Power BI Service and the bookmarks worked fine.


I suppossed that the February update could be the solution but I'm not really sure Smiley Tongue


Frequent Visitor

Sorry to bring the topic again but it is October and I am having issues with this behaviour. I have several pages or tabs each with 5 or more slicers that are "reset" after I click a button that has a bookmark attached to it.


In essence it works fine but I just found that if I select something in slicer 1, select another thing in slicer 2 and then go to another bookmark, although it seems like everything is reset, if i click the same option in slicer 1, nothing will happen.


It appears to be some sort of cache thing that it's saving my previous selection for that slicer even when the bookmark is configured to reset everthing.


Please help with this issue.