cancel
Showing results for 
Search instead for 
Did you mean: 

Bug with slicer and Bookmark in Service

In the Power BI Service, I have uploaded a project that utilized a bookmark to reset several slicers on a page.  This works smoothly in Desktop, but in the service, it does not function reliably.  Is there a workaround for this, or is this a known issue?  

 

Using the standard drop down slicer and no custom visuals.  

 

Thanks,

Status: Accepted
Comments
Frequent Visitor

This issue does remain. I downloaded on 1/22 and found it to be even worse than before. Now I am having issues on Desktop as well as on Service. Behavior is unpredictable. I have tried recreating the bookmarks and that did not help.

 

Stephanie G

Occasional Visitor

Stephanie is absolutely right. The update has now made the bookmarking in the desktop tempermental.

 

This is a major issue. Our end users are now having to hit F5 whenever moving between bookmarks to remove any filters they've applied.

 

Surely there are people out there using the bookmarks and unknowingly their end users are pulling figures from the reporting that are completely inaccurate.

 

Thanks

 

Jack

Moderator

I've made sure the Desktop team is aware of this. I know some items were pushed into the service in January that hasn't made it into Desktop yet. That could be part of the problem. 

 

I've sent this to a few folks for awareness.

Visitor

The same issue occurs with the mobile application... a client of mine has just found “inaccurate results. I’m forced to erase all the bookmaks. One the most powerful functionality of PowerBi has become a major source of doubt and troubles. How can we explain wrong numbers ??? 

Frequent Visitor

Somebody please provide an update on this issue. It's an absolute nightmare!!!!!!

Visitor

I agree, we need an update. We are having to modify out current reports just so users get frustrated with this issue. This in turn takes time and makes the reports less functional.

Visitor

Hello,

 

Do you have any new about this issue? We are working in a Power BI project for new users of this tool. The feature to reset filters using bookmarks is an option that they are expecting.

Frequent Visitor

Hi all,

 

I may have figured out how to get around this.

 

Firstly I've installed the new version of Power BI released today (6th Feb 2018).

 

Next add an image to one of my bookmarks that links to itself (hiding that image on all other bookmarks).

 

Then publish the report to the Power BI service.

 

Go back to the desktop file and delete the image you've added.

 

Finally publish the report again to the Power BI service and you should be ok.

 

Hope this works for others.

 

 

Visitor

Thanks RELJack for your comment.

  

I tried the steps but I didn't get the result expected. I would like to review with you if I'm understanding and applying them in the correct way Smiley Tongue

  

I have a simple report with one page with 6 slicers, one bookmark (not filtered by slicers) and a rectangle shape (linked to bookmark). I tried the following:

 
1.Install the last Power BI desktop version

2.Remove the old bookmark

3.Add an image

4.Create a new bookmark including the image added

5.Link the rectangle shape to the new bookmark

6.Publish the report

7.Go back to the Power BI desktop and remove the image added

8.Publish again in the Service

 

Does it makes sense?

 

Thanks again!

Frequent Visitor

Hi,

 

So your step one is the same as mine. I didn't remove any of the bookmarks!

 

I kept all the same bookmarks I already had. Added an image to one of the bookmarks (hiding it from all the others) and linked the image to the bookmark it was on so in theory it had the effect of clearing the filters but staying on the same bookmark.

 

Then I publised the report to the service.

 

Went back to the desktop and deleted the image I'd just added.

 

Published again and it seems to work.

 

Hope this helps.