Showing results for 
Search instead for 
Did you mean: 

Bug in Desktop, Version: 2.79.5768.721 64-bit (mars 2020) - Error when "Apply query changes"

I have some queries againt a Postregre Database, and prewiew in Power Query works fine, but when when I try to update it fail with this error message:

Apply query changes"

Queries Metadata:


Failed to save modifications to the server. Error returned: 'An unexpected error occurred (file 'tmsavepointvalidation.cpp', line 458, function 'TMSavePoint::VerifyProxyCreationAllowed').


I have never seen this error before... May be it has to do with the new feature enhanced metadata format?



Status: New
Advocate III

I tried to downgrade Power BI Desktop to february (Version: 2.78.5740.861 64-bit (februar 2020)). Same Power Query M-scripts work perfect in this version!


So in my opinion this is a bug in the last version!





New Member

In my case when downloading to the February version, it gives me another error when trying to open the file "Could not restore the saved database to the model"

I have made multiple changes in the model since the March version, and when applying the changes, with the March version, it is when I get the error of:
"Failed to save modifications to server. Error returned: 'Unexpected error (file' tmsavepointvalidation.cpp ', line 458, function' TMSavePoint :: VerifyProxyCreationAllowed ').
  '. "

I don't know what to try.


Advocate III

@netkik The format of the PBIX-file is changed, so I'm sorry to say that I had to rebuild the report in the feb-version from scratch. I used Power BI Helper to extract the M-code as Power BI Helper was able to read the march-PBIX-file.





New Member

Thank you very much, I will try,


Regular Visitor

This errors prompts me when i delete a group/folder in Power Query editor and try to apply changes in the model. Recreate the group/folder solves the problem.

If i delete the group without any changes to apply in the models it's ok.

New Member

That's a great clue to be careful
it is possible that I did that, I have created several groups and I have eliminated others, (but I don't remember the name)

It is a great contribution to the problem


Not applicable

Wondering if this is causing issues as well:


Upon opening an existing PBIX or PBIT file that hasn't been upgraded, the upgrade will fail if the dataset contains any of the following features or connectors. If such failure happens, there should be no immediate impact to the user experience, and Power BI Desktop continues to use the previous metadata format.

  • Python scripts
  • Custom connectors
  • Azure DevOps Server
  • BI Connector
  • Denodo
  • Dremio
  • Exasol
  • Indexima
  • IRIS
  • Jethro ODBC
  • Kyligence Enterprise
  • Mark Logic ODBC
  • Qubole Presto
  • Team Desk
  • M expressions containing certain character combinations such as “\n” in column names
  • When using datasets with the enhanced dataset metadata feature enabled, Single Sign On (SSO) data sources cannot be set up in the Power BI service

In addition, PBIX and PBIT files that have already been successfully upgraded to use enhanced dataset metadata cannot use the above features or connectors in the current version.

Community Support

Hi all, 


Please back up the pbix file, then turn off preview feature "Store datasets using enhanced metadata format" to see if the same issue occurs. 


I found a same issue reported internally: CRI 181280024. Will keep you update here once I get information. 


Best Regards,
Qiuyun Yu

Advocate I

I had the same error with march version after having activated the "Store datasets using enhanced metadata format" preview feature , save as pbit and try to open and refresh the pbit.


Turning off the preview feature, saving as pbit and open it worked fine, no error message when refresh occurred.


Clearly this is linked to this new metadata format stuff ...

Not mature yet !

Advocate III

I think this is definitely linked to the new feature (dataset) 

I have the same problem on simple PowerBIs accessing only Excel files on SharePOint. 
SO based upon the other comments, my best assumption is that the 'delete groups' without applying Changes save etc seems to be the root cause.

Going back to previous version solves the problem (when possible , but sometimes, impossible to revert back to previous version)

I have this issue with several powerBIs . very annoying.