cancel
Showing results for 
Search instead for 
Did you mean: 

Bug in Desktop, Version: 2.79.5768.721 64-bit (mars 2020) - Error when "Apply query changes"

I have some queries againt a Postregre Database, and prewiew in Power Query works fine, but when when I try to update it fail with this error message:

Apply query changes"

Queries Metadata:

 

Failed to save modifications to the server. Error returned: 'An unexpected error occurred (file 'tmsavepointvalidation.cpp', line 458, function 'TMSavePoint::VerifyProxyCreationAllowed').

 

I have never seen this error before... May be it has to do with the new feature enhanced metadata format?

 

Reagards!

Status: New
Comments
Anonymous
Not applicable

I have raised a support ticket with a similar issue at - https://community.powerbi.com/t5/Issues/Queries-Metadata-bug/idc-p/1065903#M56298

 

I spoke with a Microsoft Engineer today and they are working on a fix. There is a new version of Desktop today but that doesn't fix it. The engineer said they hoped a new version would be out at the weekend. Hopefully!

 

So perhaps download the new version on Monday and maybe it'll work?

Advocate III

Thanks!

Frequent Visitor

Got update on 8 May, still getting this error at the most inopportune time imaginable! If it's something we're doing wrong, it would be so great if someone could shed some light on this. (Even when loading no queries, I'm getting the error for something called 'Queries Metadata'.)  (No metadata previews active for a while now.)

Helper I

Same issue here. I removed the preview feature but to no avail.

Advocate III

Seems that removing the Preview feature does not change back the pbix format to previous one. You need to take a previous version of the pbix ie prior to having set the previw dataset format feature. ALternatively , to open a new pbix and copy past (with patience)

jmh

Frequent Visitor

There's another thread on this topic which indicates that Power BI Desktop makes its own backup when upgrading a file to "Enhanced Metadata Format". You should be able to restore from that backup. Details can be found here:

 

https://community.powerbi.com/t5/Issues/Error-on-apply-Power-Query-Expression-in-partition-n-a-in-ta...

Anonymous
Not applicable

Hi everyone, 

I've been in discussions with Microsoft engineers over the last 2 weeks and my issue is now fixed in the upcoming May edition. 

I have a large model of many queries and pages. When I remove all query statements and apply changes, it crashes with that error message. 

 

Their response is: 

The issue is caused by trying to delete query groups that have nested queries, so deleting the queries and then query groups (with Apply changes between) should resolve the issue until we can get the new build.

 

If you need to work around this now, they suggest the following:

 

  1. In the Power Query Editor, move all queries to the "Other queries" group
  2. Apply changes
  3. Delete all queries
  4. Apply changes

 

Hope that works for you. It worked for me. 

Frequent Visitor

Hello,

Another work around to this that I have found is copying from the source advance editor table and pasting into a new blank query. 

Thanks

New Member

Yup looks to be the enhanced metadata feature that caused the issue for me.

It seems to have defaulted to off where as the report was built with it on. Re-enabling it again seemed to fix the issue.

Helper I

Also running into this issue after applying Incremental Refresh to my dataset.

I enabled the Metadata preview feature and tried to reapply changes to my dataset.

This led to the error "an internal error has occured". 

My solution for now is to rebuild the dataset, but this will take much time and is not at all a reliable solution if it were to happen again! Is there a time frame for fixing this?