cancel
Showing results for 
Search instead for 
Did you mean: 

Bookmark Navigator: Buttons not returning to "Default" formatting after selecting another button

When I select a button in a Bookmark Navigator, it gets the "Selected" formating, then when I select another button the previously selected button doesn't change back to the "Default" formating until I hover over it.

 

The gif below shows the issue occurring in a brand new PBIX file with no custom formatting applied.

Bookmark Navigator.gif

Status: Accepted

Update:

A fix forthcoming in December Desktop and the ETA for this issue is 2021/12/13.

 

Best Regards,
Community Support Team _ Yingjie Li

Comments
amaniramahi
Resolver II

Thank you for posting this! I was coming to mention it... hope they'll fix it quickly as it caused some confusion 

rbriga
Resolver III

Hopefully they'll adress it on the December update.

This navigation set saves me tons of manual work, but this glitch is indeed noticable by users.

cbuchet
Regular Visitor

Same issue here - the status won't reset automatically and will only reset on overring. Hope it can get fixed. this is great feature 🙂

v-yingjl
Community Support
Status changed to: Accepted

As far as my test, this issue would happen when the bookmarks is invalid in Power BI Desktop. If there is one of the bookmarks work fine, when click the working bookmark in the navigator, it will direct to the corresponding bookmark.

 

In addition, as the document mentioned, the selected button is the last selected bookmark, so if the last selected bookmark is invalid, this issue would happen.

 

Anyway, since this is a preview feasure in November version of Power BI Desktop, the button functions would not be perfect which would be released in December version which you can look forward.

 

Best Regards,
Community Support Team _ Yingjie Li

rbriga
Resolver III

I'm having this issue with perfectly valid and functioning bookmarks.

The former bookmark button's design remains as "selected" along with the newly-selected one, until I hover over that former button.

 

It's a great feature, and I'm sure the Power BI will tweak it soon.

jaap_olsthoorn
Frequent Visitor

Same here, my bookmarks are all working. I dont think this is an edge case, just always happens. Also: These buttons are not considered a preview feature AFAIK (They are not in the preview menu). They are GA.

cdlawrence
Frequent Visitor

Same issue here. This report is posted to the service and neither of the bookmarks are invalid.

Hope this is fixed soon.

 

power bi bookmark navigator issue.gif

 

v-yingjl
Community Support
Status changed to: Accepted

Have submited internal to comfirm(ICM: 273860700).

Would update here as soon as possible if there is any progress about it.

 

Best Regards,
Community Support Team _ Yingjie Li

v-yingjl
Community Support
Status changed to: Accepted

Update:

A fix forthcoming in December Desktop and the ETA for this issue is 2021/12/13.

 

Best Regards,
Community Support Team _ Yingjie Li

cdlawrence
Frequent Visitor

@v-yingjl That's great!