cancel
Showing results for 
Search instead for 
Did you mean: 

BUG - Dataflows Unable to Save results in inability to navigate portal

Came across a bug recently in PowerBI Dataflows - here are the steps to reproduce.

 

1) New dataflow

2) SQL server source - use a local host database (with appropriate gateway)

3) Import data from a table in the source

4) save and close dataflow - it will ask for a name to save

5) Provide any name

6) Error message says that localhost or .\ isn't supported and thus cannot be saved.  User is taken to a view of the tables in their dataflow.

7) Hitting "Close" - prompts user to save

  • User selects "save" - prompted for name - error results "can't save data flow"
  • User selects "dont save" - the "do you want to save changes" box continues to reappear - no matter how many times you click dont save.
  • User clicks "cancel" - user is back in unsaved dataflow.

 

Additioanlly the "add new tables" or "edit tables" buttons also provide an error at this point - they state

 

Spoiler

There was a problem opening your dataflow.

Operation could not complete because a newer version of this dataflow was saved since you started editing

 

The only way out of this loop is to close the browser tab and then open a new one and navigate back to PowerBI.

 

Status: New
Comments
v-lili6-msft
Community Support

hi

I have tested it with your steps on my side, but not reproduce the problem, it works well, I could save my dataflow.

if you use another datasource to create a dataflow see if it could work.

try to clear the browser cache or use inprivate model to have a test.

and also try to use another browser to have a test.

 

 

Regards,

Lin

PeaBeeEye
Microsoft

other sources work...but i need to use localhost.  Why do dataflows not save with localhost?

I cannot use "inprivate" as log in to PBI is disabled with in private.

I am able to reproduce this issue and would be happy to demonstrate it. 

I have also confirmed the same bug with other browsers.

 

PeaBeeEye_0-1624411948851.png

 

v-lili6-msft
Community Support

hi

I used my sql as the datasource, it works well.

try to re-add this sql datasource  in the gateway, and try it again.

 

 

Regards,

Lin