cancel
Showing results for 
Search instead for 
Did you mean: 

BUG: Credentials for datasource not update for refresh

Hello,

 

I am using a connector to get information from an application's DB, which requires a token. The dataset that I have created with the data extracted from the application has been uploaded online and set up with automatic refresh. Everything was working fine, until Power BI updated, and then I started receiving an error that the refresh cannot occur because the token used is invalid. I have created a new token, updated the dataset in Power BI desktop, published and replaced existing dataset online, however, the refresh still does not work, as it is using the previous token.

 

Any ideeas how to change the credentials used by an online dataset?

Status: New
Comments
Regular Visitor

@v-chuncz-msft thank you for your reply.

 

The first post describes exactly the way that the connector is currently working, and the data is being grabbed properly when using Power BI desktop, and prior to the update, the automatic refresh worked just fine.

 

The second post doesn't quite cover the fact that it worked just fine, prior to the workspace receiving a makeover and allowing to display the lineage (dataflow->dataset->report), as well as the fact that I can also see in the application that the information is taken from, when the request for the data is coming from Power BI desktop, it's coming with the correct bearer token, and when it is coming from the online service, it is using the incorrect one. As such, it's not related to the path used to access the application.

 

As mentioned previously, I have even created a new dataset, using the correct token, since I thought that replacing the existing dataset might not overwrite the token used, but without succcess, making it seem that, as long as I use the same connector, it keeps using the same invalid token.