cancel
Showing results for 
Search instead for 
Did you mean: 

Azure cube connection issue

I have a number of PBI dashboards each using Azure analysis server cubes and up until today they all ran fine.

Today, I try to open them and I get the following error message "Windows authentication isn't supported in DirectQuery mode for this data source".

I don't use a DirectQuery for my dashboards, and a colleague has been able to open one of them without problem.

 

My PBI Desktop version seems to have been updated to Dec 2020, whereas my colleague is still using Nov 2020 so I suspect there is some problem with Dec 2020.

 

It's very frustrating and I don't seem to be able to find a way to revert back to the Nov 2020 version.

Status: New
Comments
jchappe
New Member

Worked for me as well! Thanks!

pjandliz
Advocate II

Many thanks arttuvuorin

 

This worked for me - I selected my organisation's Microsoft Account and bingo!

 

Cheers & thanks!

C-Jac
Frequent Visitor

@arttuvuorin this worked for me as well. But we've just started rolling out this out to our report builders, do I have to explain everyone how to do this or do we think Microsoft might fix this? 

v-chuncz-msft
Community Support

@pjandliz 

 

That works fine for me. You may also leave feedback at this Power BI Community forum post.

sergar555
Regular Visitor

I have a similar problem with Amazon Redshift. Writes that the source does not support DQ. Can someone comment?

CaptainRik
New Member

Solution for me was - My datasouce had been reset to Windows by the upgrade. I reset it to Microsoft Account (as it should be) in "Edit Permissions" and all is well now.

CaptainRik_0-1608289591009.png

 

rama
Frequent Visitor

Same issue

v-chuncz-msft
Community Support

@pjandliz 

 

See information on the support page.

 

Power BI customers using Azure Analysis Services as a data source and connecting with a Live Connection in the December 2020 version of the Desktop client may see the additional authentication options of "Windows" and "Basic" types which are not supported. Selecting these types will lead to connection failure errors. Users should update to the latest December 2020 version (2.88.702.0) released 12/18/2020 and choose "Microsoft account" authentication type when connecting to Azure Analysis Services data sources.

pjandliz
Advocate II

hi @v-chuncz-msft

 

That's a bit odd - my version is saying Version: 2.88.721.0

 

I reconnected via the Microsoft Account (like @CaptainRik ) and all was OK.

jburns7744
Frequent Visitor

@arttuvuorin has the correct answer.