cancel
Showing results for 
Search instead for 
Did you mean: 
0

Azure Cost Management App/Connector Refresh not working

Azure Cost Management App/Connector couldn't refresh data source recently. When refreshing (both from Power BI service and Power BI Desktop), we get the following error:

 

Processing error: The credentials provided for the AzureCostManagement source are invalid. (Source at Enrollment Number;XXXXXX.)
Cluster URI: WABI-WEST-US-redirect.analysis.windows.net
Activity ID: cc9522c4-eda8-4478-a4de-420f03eac840
Request ID: 96dece71-14e7-06b7-b4c0-bb144116258d
Time: 2022-01-24 20:53:34Z

Status: Delivered

Similar issue has been submited before(ICM: 248672937) that you can try the workaround provided by PG team:

 

The ACM connector uses the default organization directory when logging in. in the case that the customer's default directory is different than the one where the billing scope belong to, they will get this error message. 

To resolve,  here are the steps to manually specify the directory where the billing scope belongs to:

 

Prerequisites: make sure you clear all existing permissions. this should be empty before following the steps

vyingjl_0-1643079185579.png

 

Step 1:

vyingjl_1-1643079234232.png

Step 2:

vyingjl_2-1643079255868.png

Step 3:

vyingjl_3-1643079383040.png

Step 4:

vyingjl_4-1643079401022.png

Step 5:

vyingjl_5-1643079417533.png

Step 6: Enter Domain name for the organization where the billing scope belongs to

vyingjl_6-1643079446937.png

Step 7: to Get the domain name, go to Active Directory and copy "Primary Domain"

vyingjl_7-1643079535560.png

Step 8: After you hit next, Click on your account if it already exist or log in with your account via email/password. 

 

Best Regards,
Community Support Team _ Yingjie Li

Comments
v-yingjl
Community Support
Status changed to: Delivered

Similar issue has been submited before(ICM: 248672937) that you can try the workaround provided by PG team:

 

The ACM connector uses the default organization directory when logging in. in the case that the customer's default directory is different than the one where the billing scope belong to, they will get this error message. 

To resolve,  here are the steps to manually specify the directory where the billing scope belongs to:

 

Prerequisites: make sure you clear all existing permissions. this should be empty before following the steps

vyingjl_0-1643079185579.png

 

Step 1:

vyingjl_1-1643079234232.png

Step 2:

vyingjl_2-1643079255868.png

Step 3:

vyingjl_3-1643079383040.png

Step 4:

vyingjl_4-1643079401022.png

Step 5:

vyingjl_5-1643079417533.png

Step 6: Enter Domain name for the organization where the billing scope belongs to

vyingjl_6-1643079446937.png

Step 7: to Get the domain name, go to Active Directory and copy "Primary Domain"

vyingjl_7-1643079535560.png

Step 8: After you hit next, Click on your account if it already exist or log in with your account via email/password. 

 

Best Regards,
Community Support Team _ Yingjie Li

yyu018
New Member

Hi Yingjie,

 

Thanks for all the details, but it doesn't help.

We are LSP and can access our EA clients usage details via Power BI Azure Cost Managment App (Analyze Azure costs with the Power BI App | Microsoft Docs) and Power BI Azure Cost Management Connector. The connector seems OK at this moment, but the App is not working. We normally use App to get the AHUB detials/recommendations which Connector doesn't provide. The same credentails (my colleague orgnisation account and my one) were working before Christmas, but none of them working now.

Hope you can shed any light on this. Thanks. 

yyu018_0-1643081187143.png

 

Izabela_Innes
New Member

Hi,

I am experiencing exactly the same problem. Power BI AzureCostManagement connector works in Power BI Desktop, but when I am trying to insert credentials into Power BI 

 

Failed to update data source credentials: The credentials provided for the AzureCostManagement source are invalid. (Source at Billing Profile Id;xxxxxx)Hide details

Activity ID:0908a8c3-eba5-4532-a4fc-96ab25b922bc
Request ID:152103cf-2a2c-7fb9-3270-717181fd5d38
Status code:400
Time:Sun Jan 30 2022 13:08:41 GMT+0000 (Greenwich Mean Time)
Service version:13.0.17576.29
Client version:2201.4.09695-train
Cluster URI:https://wabi-us-east2-redirect.analysis.windows.net/

 

Izabela_Innes_1-1643548310446.png

 

 

Dordanosh
New Member

Hey,

I'm experiencing exactly the same problem and we are LSP too.

I'm working with the microsoft Power BI support for more than a month and they can't fix it.

@yyu018 @Izabela_Innes  are you able to connect the data with Power BI desktop? I was able to do it three weeks ago, but since then, I'm getting the same error.

MárcioB
New Member

Are there any updates on this issue?

 

I am experiencing the same problem, both trying to connect to Azure Management Cost from Power BI Desktop and from Power BI Web.

francesco_beqom
Regular Visitor

Same here @MárcioB . 

Both are not working and the workaround suggested neither 

MárcioB
New Member

Thank you, @francesco_beqom for letting me know the problem is not just with me.

 

Any updates/thoughts on this @v-yingjl ?

 

I was wondering if I could use the .csv files from the Azure Cost Management tool to do some analysis on our spendings. But I am struggling to understand how the calculations could be done. I know that this is not the main theme of this thread, but it could be a temporary solution for us, Francesco.

 

If you or anybody else knows something about it, please let us know.

 

Thank you all in advance!