cancel
Showing results for 
Search instead for 
Did you mean: 

Authentication with BigQuery : dataset refresh not working

Hello,

 

I have recently noticed that I could no longer update my Power BI datasets using the web client, neither by using the planned refresh nor the instant refresh

rufinmariette_2-1627562386083.png

 

rufinmariette_3-1627562448333.png

 

As suggested in the error message, I went to the settings

rufinmariette_4-1627562532789.png

I clicked on "Edit credentials", which showed this screen : 

rufinmariette_5-1627562588982.png

And after authenticating with any privacy level, I end up on the exact same screen as above

 

Clicking cancel brings me back to the settings, the credentials issue is still there, and I cannot access scheduled refresh : 

rufinmariette_6-1627562772406.png

 

I manage to load and refresh the data on the desktop client, so it does not look like an account issue

The version of my desktop client is : 2.95.804.0 64-bit (july 2021), and I was able to recreate the issue with a new report

I was able to recreate the issue using : Chrome, Firefox and Edge

 

Several people in my organization have this issue, however a few others manage to do refresh with their credentials

 

 

Could you please help us solve the problem?

Thanks in advance

Status: New
Comments
bmcknight
Regular Visitor

@dsaintilma-flin 

 

Your workaround worked like a charm! Thanks for sharing!

rufinmariette
Regular Visitor

@dsaintilma-flin

 

This worked for me, thanks !

 

However I'm still interested to know when the permanent fix is released, as it did not work for one of my coworkers

 

Jerome_T
Regular Visitor

Hello,

 

Thanks @dsaintilma-flin for your answer.

But for me it doesn't work either...

 

I have the next error : Impossible to connect to BigQuery datasource... status code 400

 

Jerome_T_0-1628081236641.png

 

silavmisli
Regular Visitor
silavmisli
Regular Visitor
rufinmariette
Regular Visitor

@silavmisli 

 

Thanks for sharing !

Also in production environment, it does make sense to use a service account instead of personal accounts

Will try when I have some time

rufinmariette
Regular Visitor

I tried using your solution

I used the service account's address as user name

And the value of "private_key", removing the end of line character ("\n") as password

 

I got this error : 

rufinmariette_0-1628697874477.png

Am I doing something wrong?

 

Best regards

rufinmariette
Regular Visitor

I tested today, and the issue seems to be fixed

My coworkers and myself can now perform a dataset refresh again

 

Thanks for your help !

Kayle
Regular Visitor

Hello, I tried all of the above mentioned solutions but still get the error:

 

Data source error: Scheduled refresh is disabled because at least one data source is missing credentials. To start the refresh again, go to this dataset's settings page and enter credentials for all data sources. Then reactivate scheduled refresh.
Cluster URI: WABI-NORTH-EUROPE-C-PRIMARY-redirect.analysis.windows.net
Activity ID: 7b12ef9a-8dc2-40d8-a191-c0fc13b1a80c
Request ID: fbdaa961-4fc1-e614-a136-e371b5424af8
Time: 2022-05-16 12:29:09Z

 

 

However as mentioned previously, the credentials section is greyed out. I then tried clicking on the links to the power platform admin center and was able to refresh my credentials but that made no difference. Could anyone shed some light on this issue?