Showing results for 
Search instead for 
Did you mean: 

Authentication with BigQuery : dataset refresh not working



I have recently noticed that I could no longer update my Power BI datasets using the web client, neither by using the planned refresh nor the instant refresh





As suggested in the error message, I went to the settings


I clicked on "Edit credentials", which showed this screen : 


And after authenticating with any privacy level, I end up on the exact same screen as above


Clicking cancel brings me back to the settings, the credentials issue is still there, and I cannot access scheduled refresh : 



I manage to load and refresh the data on the desktop client, so it does not look like an account issue

The version of my desktop client is : 2.95.804.0 64-bit (july 2021), and I was able to recreate the issue with a new report

I was able to recreate the issue using : Chrome, Firefox and Edge


Several people in my organization have this issue, however a few others manage to do refresh with their credentials



Could you please help us solve the problem?

Thanks in advance

Status: New
New Member

I'm having the exact same issue. I've also tried in different workspacaes and tenants

Regular Visitor

Hello, I'm having the exact same issue... 😞

New Member

Exact same issue here

New Member

Hello, I have been having this issue all day as well. My team is unable to view our reports.

Frequent Visitor

There is an ongoing issue with Bigquery connector. I talked with a Support Team from MS and they told me this will get fixed on next Service's update, due to 8/7

Community Support



A similar issue has been reported internally. The fix will arrive in early August.

CRI 251438100

Regular Visitor

Thank you for the information !


I will update this thread when I notice it's fixed

Until then do not hesitate to tell me when the fix is deployed

Regular Visitor

We're having the same issue!

New Member

Having the exact same issue here as well.

New Member

Microsoft PowerBI support shared with me this tip:


You could edit the datasource credentials by logging into the below link ( A workaround untill the fix is deployed )


Worked for me.