Showing results for 
Search instead for 
Did you mean: 

August release: Refresh never completes

Model works and refreshes in July release. Tried in August release on two machines and refresh never completes. Model contains links to Sharepoint online and SFDC. Sharepoint data loads slowly and SFDC never completes. Model includes custom functions.


How can we debug the difference between August vs July of the exact same model?



Status: New
Advocate I

I'm getting the same thing. Also with sharepoint and SFDC connections.

Frequent Visitor

Also getting the same issue.  Some objects it works fine for, but it seems like some transformations are causing it to get stuck (merge/append/data type conversions).  

Community Support

Hi all, 


Please turn off the Composite Models preview feature in August desktop version then test again. 




Best Regards,
Qiuyun Yu 

Advocate II

Hi Qiuyun ,


For this model, the app says that no preview features are turned on. However, I am using Report Page Tooltips and they are working fine, even though the box is not checked!!


Is there something wrong with the Preview Features window. Is that the bug?


See screenshot:Previews.jpg




Frequent Visitor

Hi Xerxel, I just checked my settings, and Composite preview was not turned on.  Any other ideas?

Frequent Visitor

I reverted to older version of PowerBI, and this resolved most problems.  Looks like it has something to do with August release.

Not applicable

I'm having a the exact same problem too.
Digging into it, I discover that the Salesforce Reports connector in the PBI Service (classinfo = report-detail) is also failing and when I try to reconnect with the standard OAuth2 connector, it just hangs.

However, in the PBI Desktop, I get problems with both the Reports connector and the Objects connector. I opened the Data Source settings dialog in PBI Desktop, and clicked Edit Permissions on the SFDC connector, and attempted to Edit... the credentials. Sometimes it tells me that the comnpany's authentication service is down, and on other occassion it accepts the credentials. That's weird and could explain why it's taking so long because the credentials are only accepted some of the time - otherwise, it has to create a new connection... I've seen this type of thing happen in the past when the SFDC logon API has changed and the return value isn't handled correctly by the calling code.

Anyone else tried to dig into it?

Thanks, Geoff

Advocate II

GeoffR - Do any of your rows contain Japanese characters?

Advocate II

Also - could you try inserting this step into PowerQuery to find out what is the highest row count you can get to, where it still refreshes ok?


Mine happens to be 2001 which results in a line of code which says:


 #"Kept Range of Rows" = Table.Range(#"Filtered Rows",2000,1),


If I go above this number, the next SFDC record seems to break Power BI August release. The only unusual thing I can see is that the row contains a column with some Japanese text. Was wondering if the 2000 row number is a variation on that other bug with the August release - a limit of 1000 row refreshes?






Not applicable

Thanks for the ideas, @xerxel. My data doesn't contain any Japanese (or unicode or MBCS) text. I'm looking into your suggestion above, but can you point be in the direction of details about "that other bug with the August release - a limit of 1000 row refreshes"? Thanks.