Showing results for 
Search instead for 
Did you mean: 

August release: Refresh never completes

Model works and refreshes in July release. Tried in August release on two machines and refresh never completes. Model contains links to Sharepoint online and SFDC. Sharepoint data loads slowly and SFDC never completes. Model includes custom functions.


How can we debug the difference between August vs July of the exact same model?



Status: New
Frequent Visitor

OK @xerxel. You're right about the row count. If I have a SFDC Object that has many rows in its table, I load it into Power Query, and then try the following two as the last line of PQ;

  • Table.Range(#"Prev Line", 2000, 1)
    This works fine and the one line of data is returned correctly. However...
  • Table.Range(#"Prev Line", 2001, 1)
    This fails and the UI seems to hang when trying to retrieve its one line of data. In fact, even trying to cancel the request doesn't work - it keeps hanging in the 'Cancelling...' state.

So to me, this suggests that the follow-up calls to Salesforce for the next blocks of data are either never being returned to the framework, or they are not being aligned with the first block once they do return. When I try doing the exact same thing in the July 2018 release, both work fine. This needs to be raised as a bug, but do you know if there are other bugs in this area that have already been raised against the Aug release?

Regular Visitor

Very interesting - we both have the same bug! There was a bug reported before about a thousand row limit. Looks like we have found the 2000 row limit bug!!!


Now we need @v-qiuyu-msft to get involved to accept the bug.

Frequent Visitor

@xerxel @GeoffR


Experiencing the same issue guys. After upgrading to August version, have not been able to refresh any datasets with salesforce connector that exceed 2000 row calls. I have a few reports which require less than 2000 row calls from Salesforce, and have been able to run those successfully. 


Also having the same issue with reports leveraging zendesk as a datasource. 


Currently attempting a roll back to previous Power BI version and seeing if that solves the issue.


@v-qiuyu-msft - Has this been a reported by Microsoft?

Frequent Visitor

@foodsby - I can confirm that rolling back to the July 2018 release does fix this specific issue. However, there is another Salesforce related issue within the Power BI Service.

If you publish a report that uses the Salesforce Report connector (i.e. not the Objects connector), when you view the report through the Schedule Refresh screen in the PBI Service, the Service shows the Salesforce report-detail connector as having incorrect credentails (even thought they are OAuth2). Attempting to correct them results in a time out. I contacted out SFDC guy, and he can see that the request is coming through from the MS servers, and SFDC is returning a positive response to the auth check. But that seems to be getting lost somewher on the MS side. 

**UPDATE** - the Support page is now showing the this has been identified within the MS servers, and they're 'investigating the issue'.

On the original isue, I have raised a Support tcket with MSFT, but the 3rd-party support team are being tiresome and asking for countless log files, etc. which I don't have time to organise. I think that it will be resolved faster through this Issues Forum.

Regular Visitor

Hmmm. I've never tried the reports connector, only Object connector. As we use a custom SFDC instance, the scheduled refresh has never worked for us. If @v-qiuyu-msft does not reply soon, I will also open a ticket.


In the meantime, I have started to rebuild the model from scratch in the August release and have not yet encountered the 2000 row bug. That said, in the new model built from scratch on the August version I have two tables which are reporting exactly 1000 rows returned. This seems a little suspicious to me. Will compare to the July version and report back...

Frequent Visitor



Thanks for the confirmation. Do you have any idea on where to get July version download? We did the June update but did not upgrade for July. I did a roll back to June version and experienced same issues as I did with August version.


Frequent Visitor

@foodsby - I guess it depends on whether you're using the Power BI Desktop from the Windows Store or the manual application. I use the latter, and so I have the last few PBI Desktop msi installers still in my Downloads folder. Failing that you may have some success at finding them on the internet, but obviously be careful if you're downloading executables from an untrusted source...!

Frequent Visitor

Super helpful website for rolling back to prior versions:


I was referred to the site by Microsoft when we were investigating an issue with the April update, and needed to roll back to March. Per the site, it doesn't look like there was a July version and I don't have a July version in my Downloads folder either.

Frequent Visitor

I should mention that we are facing the same refresh issue since the August update. We are able to refresh from Desktop using the June version, but both scheduled and manual refreshes in the service fail. We are currently forced to manually refresh and re-publish our models daily since scheduled refresh does not function.


all my SF dashboards and reports fail to return. how did you successfully role back to the July/June versions? i'm only able to find the august release.