cancel
Showing results for 
Search instead for 
Did you mean: 

April 2019 Gateway would not install as upgrade - anyone experienced similar?

There is something different about the April 2019 (3000.5.178) gateway install. I have a cluster of 3 nodes, all with 3000.2.52 - the 3rd or 4th iteration of the March 2019 gateway.

 

Machine 1, the upgrade worked fine.

Machine 2

  1. Upgrade fails. Returns error 1601. No clue what that means and the google didn't help.
  2. Reboot. Gateway has not been corrupt. Still works, but is still March 2019.
  3. Upgrade again. Fails.
  4. Reboot. Uninstall March 2019 gateway.
  5. Reboot.
  6. Install April 2019 gateway. Fails again! Same 1601 error. The Gateway install folder is gone from c:\Program Files\ so that isn't it.
  7. Reboot.
  8. Reinstall March 2019 gateway. Works just fine. Had to do the gateway recovery of course.
  9. Figuring I have nothign to lose, I installed April 2019 again, and it finally installed. Node 2 is now on 3000.5.178.

I haven't done node 3 yet. I'm going to let it sit for a few days. The above took about 90 minutes.

 

But for what it is worth, something in the installer routine isn't as robust as the March 2019 installer.

Status: New
Comments
Moderator

Hi @edhans

 

Here is the on-premises data gateway May version released. I tested on my side, it's able to install it successfully upgrade from March version. I would suggest you test with this May version to see if you can install it successfully. 

 

If the issue still occurs, please share the installer log with us. 

 

Best Regards,
Qiuyun Yu 

Super User II

Failed again on the same machine. Error 1601. Logs are here

When it fails, I just reboot and the older version works just fine.

Moderator

Hi @edhans , 

 

I have reviewed the log but not able to find much detail information. I would suggest you create a support ticket to let engineers look into the issue on your side. 

 

Support Ticket.gif

 

Best Regards,
Qiuyun Yu 

Super User II

Thanks. Will do.