cancel
Showing results for 
Search instead for 
Did you mean: 

Apps not showing icon for workspace

Apps no longer inherit the workspace icon and publish with the workspace icon.

 

In PBI if you go to workspaces, then members, then click the icon in the workspace you can upload a new icon.

 

However, it never syncs back to the App when you deploy the changes.

 

Is there an estimate to when this will be fixed?

 

Thanks!

Status: Accepted
Comments
Super Contributor

@OneWithQuestion

 

Based on my test, if we have already published app before change the workspace icon, the app icon will not be changed automatically until we update the app manually. You can have a try.

I've also reported this internally to Power BI Team: CRI 47464670

 

If we publish app after change the workspace icon, the app icon will inherit the workspace icon.

 

 

Best Regards,
Herbert

Established Member
Status changed to: Accepted
 

I tried that unfortunately, it still doesn't work for me.

 

I have the same experience and steps as your video up to 51 seconds in.

 

At 1:11 in your video your App Workspace shows no icon and this happens to me with ALL my app workspaces which is odd.

 

I have several, some of the apps that have icons show the icons but none of them (even those with icons in the App page) show icons on the My Workspaces area.

 

At 1:20 the workspace in the video shows the app icon, but mine never refresh to show that.

 

Basically, it seems I never get past 1:11 in your video, the updated icon never leaves the workgroup and makes it into the Power BI side.

AppWorkspacesBlank.png

 

Here is what my O365 group page looks like, with several of them having images uploaded to the system and displaying:

O365GroupIcons.png

 

They have the images in the O365 group, they just never sync back to Power BI

 

 

 

Power BI Team

Hi @OneWithQuestion,

In some cases, it takes some time for the group icons to populate.


Once you load Power BI, wait for a while until all the app workspaces get their images. After , updates made to the app will have the new image. 

In this case it has been weeks of time that passed, it just does not seem to sync over.

I am still having this issue.  I created new workspaces, opened the Members option from PBI and updated the workspace icon.

 

Then waited a few more days, it never makes its way back to Power BI and therefore never to any apps I publish.

Frequent Visitor

I'm having similar issues.  I cannot get my workspaces to pull over the icons from the O365 group at all.  Seems like there is an underlying bug.

Regular Visitor

Same issue here. When I start up the Power BI Service tile the icon for my own My Workspace appears after about 3 seconds, but none appear for the APP WORKSPACES no matter how long I leave it open for.

Regular Visitor
Regular Visitor

I just published this in the parallel thread - http://community.powerbi.com/t5/Service/app-workspace-icon/td-p/220627

 

I had an interesting situation. My team/group icons were not showing in Power BI Service Workspace list. Premier support said they had fixed something (didn't say what) and it was working again. They asked me to update an icon and it correctly showed in the workspace list, but I had to redeploy the APP for it to show on the APP's tile.

 

Subsequently, I added a photo to a group that did not have one before, and it showed up straight away. I did not like the photo so I deleted it from the group, and now none of the icons show up on my Power BI Workspaces list! I added the photo back in again, and all icons reappear. Deleted the photo and all icons disappear. Tried it with a second group icon and the same happens.

 

If a team or group never had an icon in the first place then it is ok, but if any team or group has had its icon deleted, then no icons show in the Power BI Workspaces list.

 

Try adding a simple icon to each team/group.