Showing results for 
Search instead for 
Did you mean: 

Apps not showing icon for workspace

Apps no longer inherit the workspace icon and publish with the workspace icon.


In PBI if you go to workspaces, then members, then click the icon in the workspace you can upload a new icon.


However, it never syncs back to the App when you deploy the changes.


Is there an estimate to when this will be fixed?



Status: Accepted

Thanks, I'm trying that now (updating all my groups to have an icon)

Frequent Visitor

Hi everyone.


Is there a fix for this issue? I have exactly the same problem since 3 weeks ago.


I can't change App icons. Group icons are different from App's.



Workspace icons aren't shown.







Regular Visitor

I have reraised it with MS support.


The workaround is as follows, if a team or group never had an icon in the first place then it is ok, but if any team or group has had its icon deleted, then no icons show in the Power BI Workspaces list.


Try adding a simple icon to each team/group.

Frequent Visitor

I added one icon to each group (actually, I changed icons since all groups already had one).. Nothing happened.


Later, I deleted all icons, then I waited some time, then I added again one icon to each group.. Nothing.


Maybe I'm missing something, but it didn't really work for me Smiley Sad

Regular Visitor

Sorry to hear that. That workaround had solved my problem, so maybe you have a cache issue in your area. I am off North Europe, and we often get cache issues with usage metrics.


It was quite strange to start with, as a collague had the icons showing in his workspace list and I didn't, but we were members of some groups the same and some different groups, and it was one of the groups I was a member of that had had its icon deleted so stoped all of my icons showing but his were ok. When I deleted an icon from one of our shared groups then both our workspace lists stopped showing icons. Adding an icon to every group fixed out problem.


Hope you get your problem sorted.



Frequent Visitor

My case was a bit different. Everything was doing well having synced custom icons in both O365 groups and Power BI workspaces.


I needed to change the icon of one PBI workspace so I went to the corresponding O365 group and I changed it from there. It was supposed that it would change the workspace icon in PBI service as they are in sync. Unfortunately that didn't happen. Change only took effect on O365 group. PBI workspace icons were all gone, not only for me but for all my colleagues members of that workspace. 


Furthermore, if I can't change a workspace icon then I'm not able to change App icon neither. 


I've been trying different approaches to solve the issue and none has worked. Maybe it's a cache issue as you suggest, I'm located in South America. 


I hope this is solved soon as I have internal costumers demanding changes and it's frustrating to answer this simple task is not possible Smiley Indifferent


Thank you Andrew for your reply. 






Regular Visitor

Microsoft have just told me that a fix for the missing icons has just been rolled out. I have tested it and it works now i.e. all icons show in my workspace list even if one workspace has had its icon deleted.


But you still need to update the APP for the new icon to show on the APP.

Frequent Visitor



Yes, you are right. I also tested it and now all icons are shown correctly!


Thank you for your support! Smiley Very Happy


Best Regards,



Regular Visitor

Hi guys, that's all nice but I have the same problem as @OneWithQuestion.

I don't have a pencil icon to change a workgroup image.


I am the owner of the workgroup.

Do you have any idea?


not working again 2019-01-28.  fix it!