cancel
Showing results for 
Search instead for 
Did you mean: 

Anyone else having issues with plotly?

Since Saturday we're expierencing severe issues with custom R-Visuals that use plotly in PowerBI service.
The visuals won't load at all and just give the error message "Missing Dependency For A Known R Package. Package 'plotly' has a dependency that is currently unavailable".

 

Everything works fine in PowerBI desktop so my guess is that some R-libraries have been updated on the PowerBI servers that cause plotly to break. This has indeed been an issue and cause of visuals not loading anymore in the past.

 

Is this something anyone else is expierencing?

 

Cheers,
Arne

Status: New
Comments
mdferris
Regular Visitor

Pretty urgent that this gets fixed - got a custom viz using plotly in a report embedded in an app that can get viewed hundreds of times a day by users.

jneil
Regular Visitor

Any update on this issue? Built a platform with a go-live in under a week. Need this updated ASAP.

Sichanm
Helper II

Same issue here, 

 

Missing Dependency For A Known R Package

Package 'plotly' has a dependency that is currently unavailable

Please try again later or contact support. If you contact support, please provide these details

wouterDefour
Frequent Visitor

Saw this on Ms support page:

Power BI customers using the plotly R Package may see visuals not load with a "Script Runtime Error" message. Engineers are working on a fix and expect it to be deployed by end-of-day 03/04/2020.

 

Looking forward to the fix

TomTomTom
Helper I

thanks @wouterDefour 

 

hope that's mm/dd/yyyy

jneil
Regular Visitor

Anyone have any input on how realistic 03/04/2020 is? Any predictions on if this fix will come earlier or later? Doesn't seem like it should be a hard fix to make on the server side since the package worked 7 days ago. Any actions that can be done to escalate this issue more?

jneil
Regular Visitor

Microsoft has patched the error on the service!

malikaditya
Frequent Visitor

Hi Everyone,

 

Did it get resolved? I am still getting the same error?

 
 
 
malikaditya
Frequent Visitor

error.PNG

sr2020
Regular Visitor

Hi All,

 

its working for me..I believe as committed ( even took more than expected) MS, fixed the issue.