Showing results for 
Search instead for 
Did you mean: 

Analyze in Excel not working after updating Office 365 to latest update (Version 1709)

Users starting reporting that their Analyze in Excel feature is not working anymore in Power BI. The organization is heavily dependent on the reports and due to this feature being stopped working, we are facing severe issues. 

Please help any MSFT member.


Status: Needs Info



Could you please provide the screenshot for the not working scenario? We may able to provide a temporary workaround according to the specific error message.


Best Regards,

Impactful Individual
Status changed to: Needs Info
Advocate II

I am having similar issues whereby Excel spreadsheets can no longer connect to PBI service. It has started happening to my spreadsheets sometime in the past month but I cannot say what was the trigger. In my case I am using Excel 2016 standalone so it's not just about Office 365.

There is a community post that seems to address this but I'm not sure what action is being taken ...

My comment on Sat 4th Nov describes the result I'm seeing when I try to connect to the service.

This is becoming extremely urgent as we have around a dozen spreadsheets that depend on sourcing data via the live connect to PBI Service.

best regards, Garry





  1. Verify excel version - 32 or 64.
    Go Excel -> Files -> Account -> About Excel.
    Analyze in Excel not working after updating Office 365 to latest update (Version 1709)_1.jpg
  2. Go to: "C:\Program Files (x86)\Microsoft Office\root\VFS\ProgramFilesX86\Microsoft Analysis Services\AS OLEDB\140" for 32-bit excel version or to: "C:\Program Files\Microsoft Office\root\VFS\ProgramFilesX64\Microsoft Analysis Services\AS OLEDB\140" for 64-bit excel version
  3. Right click on the adal.dll -> Properties -> Details tab and check that the 'Product version' is 1.0.2044.0414 (this is the "bad" adal version)
  4. Close all office applications
  5. Rename the adal.dll file to adal_orig.dll
  6. Download MSOLAP 7 from here:
  7. Go to: "C:\Program Files (x86)\Microsoft Analysis Services\AS OLEDB\130" for 32-bit excel version or to: "C:\Program Files\Microsoft Analysis Services\AS OLEDB\130" for 64-bit version and copy the adal.dll to the location in step number 2
  8. Go back to the location in step number 2 and check that the version of the adal.dll is now: 1.0.2028.318
  9. Now try to open the odc file again and see if it works for you

Best Regards,
Advocate II

Thanks Herbert but no luck there.

I am using 64 bit Excel. The adal.dll was indeed the "bad version".

Installed the MS Analysis Services stuff, copied the new adal.dll across and checked that it was the new version as you instructed.

I opened Excel to a blank page. On the Power BI tab I logged out of my connection and logged back in just to be sure. Tried with "Connect to Data" to connect to an existing dataset, and I still get this error:

screenshot - error.png

Advocate IV

We have also had this problem when using 64 bit Excel. We have found that the issue is the following DLL file. If you use the most recent version it seems to create issues. Roll back to an over version of the DLL file and Analyse in Excel is fine.


C:\Program Files\Microsoft Office\root\VFS\ProgramFilesX64\Microsoft Analysis Services\AS OLEDB\140



Advocate II

Thanks dcresp, I had actually been working with the older version of adal.dll, and I upgraded it to latest version per Herbert's advice earlier in this thread. But that didn't work for me and of course neither did the old version.


However, I'm happy to report that the problem has now gone away. It seems to be related to Excel having been updated to build 1710. Not sure when this update was applied, but the connection to PBI Service is now working. (Build 1710 was reported on another thread as having rectified the problem).


Thanks to all for your help.

Advocate IV

We have tried updating the DLL on another computer and this did not work. We also updated to 1710 and this has also not resolved the issue.


We had a computer that was working OK which was then updated to 1710 32 bit and it is now not working.


We are plannign to use Analyse in Excel as a core part of our modeling infrustructure but need it to be stable and working. 


We have some computers where Analyse in Excel works perfectely and others that we can not get working. If anyone has any ways to resolve this it would be great to hear.