cancel
Showing results for 
Search instead for 
Did you mean: 

An item with the same key has already been added - since June 2017 update

Hi everyone,

 

I've updated to the new version of Power BI for June 2017 (2.47.4766.542) and since then my report isn't working anymore. It's been working fine for months but since this update, it gives me the following error : an item with the same key has already been added. I've searched for a solution and I've tried many things but none of them worked. I've gone back to the previous version of Power BI and the report is working again. The problem seems to be in the data that's coming from an Excel file. 

 

Does anyone have the same issue? 

Thanks,

Nina

Status: Needs Info
Comments
Helper II

@JonBaylis Thanks, new build 2.47.4766.801 has fixed the issue for me. 

Frequent Visitor

Yes, new update has solved the issue.

thank you. 

Regular Visitor

Same problem

Regular Visitor

same problem

Community Support

Glad to hear the issue fixed after updating the desktop. Thanks for @JonBaylis's sharing.

 

@MRCL Did the same problem occur after you update the desktop to version 2.47.4766.801 64-bit (June 2017)?

 

Best Regards,
Qiuyun Yu

New Member

I am experiencing this issue now for hte first time after updating to Version: 2.51.4885.701 64-bit (October, 2017). It happens only with one table and is exactly as the OP described.